server hangs on overload

Discussion in 'Installation/Configuration' started by cotthemh, Mar 1, 2007.

  1. cotthemh

    cotthemh New Member

    my server gets in to a complete overload on clamav and spamassassin, the processes just keep piling up, i tried stopping postfix, but they continue to come. Whatever i try it always blows up my server, is there a way to stop this ???? help help help
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure that the processes did not stop when you stop postfix?
  3. cotthemh

    cotthemh New Member

    actually if i do /etc/init.d/postfix stop

    it gets restarted somewhere. The only thing which helps is to close down the smtp port on the firewall, then it gently slows down. i reduced the number of smtpd in the to 10 and the local_destination_concurrency limit to 10, the local_recipient_limit to 200

    still to high ???? i have a grand total of about 200 mailboxes ...

    many thanks for you're advice
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you maybe tell ISPConfig to restart Postfix if it's not running (under Management -> Server -> Services -> Monitoring)?
  5. cotthemh

    cotthemh New Member

    no, but the real problem is the generated overload. The server generates an average load of up to 300 and then just goes down. If you monitor processes its just scanning (clamav and spamassassin), it just keeps on generating these processes. probably due to the fact that 1 of my customers has about 150 maiboxes which receive massive amounths of spam. So i would like to know how i can deal with this to avoid the server going down.:confused: :confused:

    my guess is the server starts postfix before ispconfig and ispconfig just starts it again after i shut it down. because if i shut it down afterwards it keeps down, but due to the heavy load which i get by that time the command just does not get through anymore.:(
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The only solution I see for this problem is when you switch to spamd instead of calling the spamassassin script. But you will either loose the possibility to configure your spamassassin settings in ISPConfig or you will have to patch the ISPConfig sources to create a symlink to the .user_prefs file so spamd finds it.

Share This Page