Server config on xen virtual server

Discussion in 'Installation/Configuration' started by wxman, Apr 19, 2009.

  1. wxman

    wxman New Member

    I have ISPConfig running on a Xen virtual server, on Ubuntu server 8.04. I also have HAProxy/Heartbeat on another virtual server on the same machine.

    My question is, how do I set the server config, server IP, etc. in the ISPConfig control panel? I'll be adding more sites as soon as I can, but I don't think I have the initial setup correct yet. For example; under Server config, I have my web1 server listed. If I click that, I have a checked checkbox, I changed the nameservers, and gateway to reflect the correct settings, but what IP address do I use. It started with, so do I keep that, change it to my local IP for that virtual server, or use my public IP that I want to access the sites with?

    I think Apache isn't configured right yet, but I'm not sure how/where to edit it because I know ISPConfig changes things. Does apache still use /etc/apache2/sites-available/default after ISPConfig takes over? I need to find a way so it doesn't log all the load balancer requests from HAProxy.

    Are there any tutorials/help around for setting up version 3 yet?

    Sorry about all the questions. I love the new interface so far, since I made the move from version 2. I'm anxious to start adding sites.

    UPDATE: I'm able to access ISPConfig from the Internet now. I had the wrong port open in my firewall/router. I also added a test website, but I can only access it by, now It's getting there though.
    Last edited: Apr 19, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    You must use one of the IP addresses that you see in the output of
    , but don't use 127.0.x or your sites won't be accessible from the outside.

    Yes - take a look at
  3. wxman

    wxman New Member

    On which virtual server do I find the IP's? The web server, or the load balancer? I'll have to wait on the because I think my load balancer isn't set up correctly yet. I might have the wrong IP's there now. I changed System>Server config, and Edit Server IP, to the local address I set for this server of I just checked, and now I can't get to my test site at all. I made sure the DNS entries use the correct public IP just like shown in message

    I also can get to the ISPConfig interface using my public IP with :8080.

    I looked through these already. What I kind of wanted was a more detailed description of all the different pages, settings, etc. inside ISPConfig. I'm sure I'll figure it out.

    If I'm using myself as NS1, like I had before running ISPConfig 2 and Bind, can I be my own namserver again with version 3? Do I need to set up ns1 as it's own "site" in ISPConfig. Before I had to set up a site in ISPConfig for my nameserver domain of Do I do that again here?
    Last edited: Apr 20, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    The web server.


    No, just go to the DNS Manager (btw, this was possible in ISPConfig 2 as well - no need to create a site first).
  5. wxman

    wxman New Member

    I think that makes sense now. I'll use the local IP I set up for the web server. Do I put it in both the Server config and the Edit Server IP?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If you run the server behind a router, you will have to use the local IP. If your server is connected directly to the internet, then you will have to use the public IP.
  7. wxman

    wxman New Member

    The web server is using the local IP of It's accessed through a router/firewall that has my public IP aliased to the local IP. This is going through HAProxy on a separate Xen virtual server. I'm still trying to get the bugs out of that as well, but I figured if I got ISPConfig set correctly, it would help debug my load balancer.

Share This Page