Server Config: ERROR Invalid Hostname.

Discussion in 'General' started by CK13, Dec 22, 2014.

  1. CK13

    CK13 New Member

    I just installed ISP Config on Debian 7 and when i go to server config page i get ERROR Invalid Hostname.

    What is causing this and how can i fix it?
    Did i do something wrong in the installation process?

  2. CK13

    CK13 New Member

    I changed the hostname in the VPS control panel to the domain name, reinstalled ISPConfig and now it is working.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The hostname is a fqdn like So the text string that you entered (or that was set by your virtual server controlpanel for the vm) is a wrong hostname and therefor ispconfig rejected it.
  4. MQuintana

    MQuintana New Member

    then it means that ispconfig 3 requires dns server to function ?? Because if it need a FQDN ??
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No. It just means that you have to enter an FQDN and not just the local part as some software like amavis will not start without it.
  6. uniQ

    uniQ New Member

    I ran into the same problem today. I was testing the new ISPConfig when I encountered this error.
    Is there a way to change the hostname on my system without loosing my data/ISPConfig installation?
    Already tried changing /etc/hosts, /etc/hostname and rebooted but nothing changed.

    Step by step guide would be highly appreciated. Server is running on Debian 8.5 Jessie with Apache2, BIND, Dovecot & ISPconfig 3.1b2. :)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to set the new hostname in the hostname field of the server config in ispconfig as well. Beside that, the wrong hostname can also be in the files /etc/mailname and /etc/postfix/
  8. uniQ

    uniQ New Member

    Problem is, that I can't change the hostname in ISPConfig, since it also results in the error message 'Invalid Hostname'.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The message occurs when the hostname that you entered contains an invalid char. A valid hostname is e.g.
  10. pelikancz

    pelikancz New Member

    Why is it impossible to let the hostname be and go to different tab (e.g. Cron) in this settings? It still won't let me even when I didn't change it and use just what was preconfigured.

    To be honest I don't know what will change to that hostname do, because I have preconfigured server from my VPS provider. I don't want to create some mess when I don't know what this settings affect...
  11. Peter Richardson

    Peter Richardson New Member

    I had the same issue, but I managed to fix it by reviewing and fixing discrepancies in the two /etc/hosts files on the two machines in the cluster. Now they're both identical, but I still have one issue in ISP config - they're still showing the old names (see attached images). They should be and They have updated inside the Server Config page, but not on the previous page (Server Configuration - the one shows you the two servers)

    Attached Files:

Share This Page