Server can't resolve Update Site

Discussion in 'HOWTO-Related Questions' started by norbie, Sep 23, 2012.

  1. norbie

    norbie New Member

    I am running a multi server setup with ISPConfig3;
    Web Server (64bit) :)
    Mail Server (64bit) :mad:
    DNS Server 1 (64Bit) :mad:
    DNS Server 2 (32Bit) :mad:

    on Ubuntu 12.04 LTS.

    Up until a few days ago everything worked as expected.
    Then, two of the server DNS1 and DNS2 didn't know how to resolve to the Ubuntu Update Server while the other two (mail / web server) where able to connect and update / upgrade.
    In the mean time the mail server has lost it too, simply can't resolve to the ubuntu servers, but knows how to get to other places.

    Other than that, the do resolve and act as they should, except very slow in some instance. For example: ISPConfig3 Web Panel takes up to 5 Seconds or more to built the 1st screen. But afterwards is reasonably fast again.

    I know for sure that there are Kernel updates since I just upgraded a 32 Bit server within my network, however has nothing to do with ISPConfig.

    The Apt log file ends a few days ago on the DNS1 / DNS2 server and has no new conclusive entries.
    I have absolutely nothing done manually that would lead me to think that I changed something to the worse.
    It seems that one or more updates in the past simply caused the problem with the resolve.

    Or, I just don't update anymore, also a shot into my own foot.

    Also I noticed that the response from my server would become longer and longer during logon. I am logging in over the LAN using SSH and have Gigabit hardware.
    This also would lead me to think thjat there is something with bind is not working right?

    Is there anyone that may have gone the same path as I did and trustingly updated / upgrade and now sees the same behavior?

    Input is appreciated!
    Last edited: Sep 23, 2012
  2. norbie

    norbie New Member

    Problem resolved

    Don't you love it when people actually solve their problems?

    I don't completely understand what happened, however through hours of search and carefully looking at various configuration files, I finally traced the problem to one or more NIC configuration problems. The system worked flawless before.

    I am using two 1 Gbit NIC's in my servers. One serves the public IP and the other one is for the LAN, working independently (no bridging I don't need it).
    For whatever reason, the interface configuration file suddenly was missing the second Card parameters, IP's etc.
    This is just part one of the mistery!
    From my desktop unit that I use over SSH to administer the servers, I had no problem to get to the servers via LAN, slow login of course. Remember, there was no LAN card configured, at least not in the config file.
    IFCONFIG did not show anything on eth1 either, as I found out later.
    TOP was showing very low system loads and nothing unusual.
    But it was slow, I mean really slow.
    Also, I rebooted with this configuration, yet I still could access from the LAN at this time I hadn't checked the NIC config yet.
    Since I still could access, it didn't cross my mind to check on the NIC's. It had to resolve somehow!
    My websites admin panels would slow down, as if it would be on a 10 Mbit or token ring net or even slower, fast back then, though. Any change to a web page, was a painful waiting game.
    Only by accident did I notice that my nic's had dissapeared and the nameserver entries too.
    I guess, some higher power only, knows how the system resolved hosts and websites. I theorize that it went to some place got some idea, timed out a few times and then went to some other place, doing the same, to come back to my secondary DNS to get the final piece. The secondary was the only one that did work. Coincidentally, this machine is the slowest and has only one NIC. All of that started probably a week ago after an update that made things better for me.
    Manually reentering the missing data and a reboot on all systems seemed to give em a turbo charger. Suddenly everything ran at expected speed.
    I still am not sure, what caused the problem in the first place, since I didn't change anything through the ISP control panel nor at the command line, other than the apt.
    I noticed at least one update for BIND flying by, wonder if they changed the config file structure and did override my network settings for some reason?
    It is a mystery!!!
    But, I won't complain anymore since it is up to speed :), until next time when murphy moves in. :mad:

    Last edited: Sep 24, 2012

Share This Page