server cant resolve names

Discussion in 'General' started by vulfs, Jan 20, 2008.

  1. vulfs

    vulfs New Member


    Just got a strange problem.

    All of a sudden the server can't resolve outside hostnames.

    Have checked resolve.conf it is OK


    If i ping them here from laptop the respond.

    If i ping fx. the server replies after LOONG time:

    PING ( 56(84) bytes of data

    I discovered the problem because when i sent mail trough server they got back like this: 450 4.1.2 <[email protected]>: Recipient address rejected: Domain not found

    If i tail maillog it says fx

    Jan 20 16:22:03 naja postfix/smtpd[4155]: warning: RBL lookup error: Host or domain name not found. Name service error for type=A: Host not found, try again

    Have tried to reload bind, AND tried to restart server

    What is wrong??:confused:

    Forgot to say, the server recieves mails, and reply to all requests

    Resolved... dont know how.. was sitting and trying to ping different host, both by names, nad by IP.
    And all of a sudden, everything responded as it should??

    Anybody have any ideas??
    Last edited: Jan 20, 2008
  2. zetnsh

    zetnsh New Member

    First of all, very glad to hear it resolved itself, but I understand that it would be nice to have a bit of peace of mind and find out what went wrong!

    Everything seems to point to a DNS error, but if you have resolv.conf set up with 3 valid nameservers, I can't see why it wouldn't be able to resolve names, other than if there was a temporary connectivity problem with your internet provider, particularly if suddenly it starts working again. I have had odd things like this happen in the past too.

    To prevent it happening again, have you considered setting up your own machine as a cacheing nameserver? That way you could use your own server IP as the first one mentioned in resolv.conf.

    Good luck!


Share This Page