Server accepts mail for mail@ - addresses

Discussion in 'General' started by RicochetPeter, Apr 21, 2006.

  1. RicochetPeter

    RicochetPeter New Member


    I have a working configuration with Ubuntu 5.10 and ISPConfig 2.2.0. Everything seems to be alright, except one strange thing:

    The server accepts mail addressed to addresses of the form mail@[domain] where [domain] is all of the domains set up on this server. Postfix (or is it procmail?) puts the mails to /var/mail/Maildir/ and I simply don't understand why this is so. Any hints?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the "mail" email address listed in one of the postfix config files, for example the aliases or virtusertable?
  3. RicochetPeter

    RicochetPeter New Member

    nope, that's why I find it so strange.

    here's my
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/aliases? Is mail a user in /etc/passwd?
  5. RicochetPeter

    RicochetPeter New Member

    Yes falko, mail is a user in /etc/passwd. Can postfix be forced to only accept mail to addresses in the virtusertable?

    Come to think of it, I do not want that either, cos a few minutes ago I figured out how to make mailman work with the ISPConfig setup... :rolleyes: :cool:

    As a hint to all who want to do this too, with Ubuntu 5.10/ISPConfig:

    I chose a certain domain for being the mailman domain. Let's call it

    1) Create web for this domain in ISPConfig
    1.1) You need to add these Apache Directives in the base data for the web:
    2) apt-get install mailman

    3) make the changes to the postfix config files as mentioned in /etc/mailman/, except for the relay_domains paramter, you don't need that.

    4) yes, you have to make the change in like it's written in that script, so the line needs to be
    (note the fourth value is not a dash, but an n, and all of this is one line - or indented second/third lines)

    5) do a postconf -e 'local_recipient_maps ='
    If you don't, your postfix will not accept a single mail for the mailman domain. Heck, this cost me like two hours or so!

    6) change /etc/mailman/ to
    You will need to copy the three images to that location inside the web directory. There might be more clever ways...

    7) now you could do a "newlist mailman" and the an /etc/init.d/mailman start
    Last edited: Apr 23, 2006
  6. oliver.blaha

    oliver.blaha ISPConfig Developer ISPConfig Developer

    Yes ;)

    In /home/admispconfig/ispconfig/lib/ you can switch an option from sendmail style to postfix style. Just do this and your sorrows will be gone ;)
  7. RicochetPeter

    RicochetPeter New Member

    That's nice to hear, Oliver. I belive you're talking about this line here
    Next question: what will happen when I change this from 1 to 2, or: where can I find info about what this value does?
  8. falko

    falko Super Moderator ISPConfig Developer

    The format of /etc/postfix/virtusertable and 7etc/postfix/local-host-names will change, that's all. :)
  9. oliver.blaha

    oliver.blaha ISPConfig Developer ISPConfig Developer

    The result of the changed format is that your virtual domains won't be treated as local domains anymore, so they won't accept local accounts as mail aliases.
    You won't need to change anything else.
  10. RicochetPeter

    RicochetPeter New Member

    OK, this actually solved the problem I opened this thread for. But created another one: my listserver domain is now a VIRTUALDOMAIN, which seems to take precedence over the transport_map.

    Is there any chance of ISPConfig not listing any of the domains it knows in the virtusertable as "VIRTUALDOMAIN"? Or other ideas?

    OK, for those who followed my little mailman howto:

    You will now have to deal with aliases :mad:

    In the virtusertable you will need to add the entries for all the list addresses in postfix format in the MANUAL sesction, i.e.:
    and so on.

    In /etc/aliases you will need to add all the command lines needed for mailman:
    and so on...
  11. falko

    falko Super Moderator ISPConfig Developer

    You can set the domains to "External Mailserver" in ISPConfig, then ISPConfig will not add them to the Postfix configuration.
  12. RicochetPeter

    RicochetPeter New Member

    Waaaah, cool! YOu guys seriously rock byg tyme!

    Again, for those who have read the mailman thingie:

    Forget the alias fiddling, it works like described in first "howto". Just set the domain to external mailserver :)

Share This Page