Serial Modem setup on Ubuntu 16.04

Discussion in 'Installation/Configuration' started by Marmotte729, Oct 6, 2017.

  1. Marmotte729

    Marmotte729 New Member

    I have an old HP Compaq desktop that I'd like to use for an Amateur Radio application. This involves setting up an old modem connected to the RS-232 DB9 port on the back of the desktop.

    I've identified the port's device file as /dev/ttyS0. When I point my terminal emulator (picocom) to it, the lights on the modem come on. The SD light also blinks when I hit a key on the keyboard. Thing is, I don't see any response from the modem. When I type AT I should get back "OK". I get nothing.

    Looks like Ubuntu uses that port as the console. I wonder if the modem's replies are going to the OS and not the terminal emulator. I'd like to disable or unconfigure the console but can't figure out how to do that. Anyone have any pointers or comments?

    Thank you
  2. ISPConfig Developer ISPConfig Developer

  3. Marmotte729

    Marmotte729 New Member

    Thank you for your reply. You are correct in saying it should work, in fact it is working. The problem was with the modem, it was not telling me what it was doing. I was able to confirm the modem was working once I issued the ATQ0 command, to not suppress the reporting of result codes. After that, typing "AT" got the "OK" back on the terminal emulator.

    BTW, I let the terminal emulator set the paramaeters:
    > picocom -b 9600 /dev/ttyS0
    (picocom by default sets 8 data bits, No parity and 1 stop bit)

    Thanks again!
 likes this.

Share This Page