SEO Redirect visual "bug"

Discussion in 'Developers' Forum' started by MacGoose, Nov 19, 2011.

  1. MacGoose

    MacGoose New Member

    I love the new SEO Redirect non-www -> www

    Anyhow, it redirects from mydomain.com to www.mydomain.com//

    It somehow adds two trailing slashes

    I'd say it's not how it visually should be

    Thanx!

    , MacGoose
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you use 3.0.4 Final or the beta? As far as I remember, this was a bug in the Beta and was fixed in the final version.
     
  3. MacGoose

    MacGoose New Member

    Oh sorry for not including this in my original post.

    As far as I know I'm using the Final version. Downloaded 3.0.4 yesterday. No upgrading. Downloaded and installed on a clean system.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker, so we'll check it.
     
  5. defconjuan

    defconjuan New Member HowtoForge Supporter

    SEO Redirect

    Okay—and yes, I own the manual and am using the latest stable—I still cannot get domain.com to always redirect to www.domain.com and perhaps I'm doing it wrong. Here's my settings:

    [​IMG]

    Aliasdomain: domain.com
    Parent Website: www.domain.com
    Redirect Type: [Null/None Selected]
    Redirect Path: [Null/None Selected]
    Auto-Subdomain: None
    SEO Redirect domain.tld => www.domain.tld
    Active: checked

    And yes, the parent website www.domain.com exists and it's DNS settings are correct. The goal is a clean 301 N,R redirect from domain.com to www.domain.com. I usually do this with some apache directives and mod-rewrite but that's a heavy handed solution for this if the control panel has the functionality.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no known issues in that function in current ispconfig releases.

    The controlpanel does the same. Take a look at the vhost file.
     
  7. defconjuan

    defconjuan New Member HowtoForge Supporter

    thanks for the quick reply

    But to be clear, with what I'm trying to accomplish, my depicted settings would be correct yes?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Your setup is a bit too complicated. Normally you would set it up like this:

    website: domain.tld
    auto subdomain: www
    Seo redirect on the redirect tab of the website: domain.tld => www.domain.tld

    thats all. A alias domain is not required here.
     
  9. defconjuan

    defconjuan New Member HowtoForge Supporter

    Ahhhhh. Okay, let's try that out. Thanks again.
     

Share This Page