Sendmail- / Webmail-Issues

Discussion in 'Installation/Configuration' started by julez, Aug 11, 2006.

  1. julez

    julez New Member

    I have ISPConfig 2.2.6 installed on SUSE 10.1 with the following daemons/tools:

    -sendmail
    -procmail
    -qpopper
    -dovecot

    hostname is: mr2.xxxxx.de
    vHosts for different webs are all: (www.)xyz.xxxxx.de [e.g. www.test01.xxxxx.de]

    We need sendmail and qpopper for compatibiliy reasons.

    But there are two issues:

    1. eMail-login with POP3-client and with roundcube do work fine. Sending eMails and receiving eMail from e.g. [email protected] does work. When using reply in any client [webmail or remote POP3/SMTP-client], the reply-to-address is [email protected].

    How and where can i fix that?

    2. for compatibiliy reasons we need to add an X-Envelope-To header to all eMails with a global /etc/procmailrc like this:

    Code:
    ENV_TO=$1
    :0f
    * ENV_TO ?? .
    | formail -i "X-Envelope-To: "$ENV_TO
    
    :0fE
    | formail -i "X-Envelope-To: UNKNOWN"
    
    Now the 2nd problem: procmail.log tells me $1 is always empty resulting in "X-Envelope-To: UNKNOWN" - should be e.g. "X-Envelope-To: [email protected]"

    I already killed all .forward files for the account calling procmail, because Mlocal in sendmail.cf is procmail.

    Code:
    ##################################################
    ###   Local and Program Mailer specification   ###
    ##################################################
    
    #####  $Id: local.m4,v 8.59 2004/11/23 00:37:25 ca Exp $  #####
    
    
    Mlocal,         P=/usr/bin/procmail, F=lsDFMAw5:[email protected], S=EnvFromL/HdrFromL, R=EnvToL/HdrToL,
                    T=DNS/RFC822/X-Unix,
                    A=procmail -a $h -d $u
    Mprog,          P=/bin/sh, F=lsDFMoqeu09, S=EnvFromL/HdrFromL, R=EnvToL/HdrToL, D=$z:/,
                    T=X-Unix/X-Unix/X-Unix,
                    A=sh -c $u
    
    Any useful hints are very appreciated.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Why don't you use Postfix? http://www.howtoforge.com/forums/showthread.php?t=4697&highlight=postfix sendmail compatibility
    It even comes with a binary called sendmail for compatibility reasons.

    Did you set the correct sender address in your email account in RoundCube?
     

Share This Page