Sendmail Trouble, Emails don't turn up in most inboxes

Discussion in 'Server Operation' started by Ralle, Sep 5, 2007.

  1. Ralle

    Ralle New Member

    Hello guys!
    I have been browsing this site a lot and I am very happy with it.

    I have a problem with the mail server.

    I installed CentOS which came with sendmail I guess.
    I then compiled Lighttpd, APC and MySQL and installed it all.

    Then I set some MX records for my domain (

    But after having set up a server my own (this one), only emails to and some other systems are properly sent.

    I tried to look at, check it here:

    And I realized that it cannot connect to my mail server.

    I have tried:
    $ service xinetd start
    But that didn't help.

    Then I searched on google and didn't find much help.

    What do you suggest I try?

  2. chuckl

    chuckl New Member

    A good starting point is to go to and do a DNS Report on your domain. Check the mail section, and fix any errors they flag.
  3. Ralle

    Ralle New Member

    Connect to mail servers
    ERROR:  I could not complete a connection to any of your mailservers! Timed out [Last data sent: [Did not connect]]
    If this is a timeout problem, note that the DNSreport only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
    OK, so this is my exact problem. But what could be wrong?
    I went to the "system-config-securitylevel-tui" menu and enabled SMTP.
    Sendmail is running on default config of CentOS.
    I read something about sendmail normally is internal. Not connectable from outside.

    What do you think?
    Last edited: Sep 5, 2007
  4. chuckl

    chuckl New Member

    Sendmail is an aspect of mail, it can be a complete package - i.e. sendmail, or it can be another mail server e.g. exim, postfix, qmail etc masquerading as sendmail for backwards compatibilty. Mail servers usually use SMTP to transfer mail between domains
    Did you follow one of the Perfect Setup guides? If so, you have probably Postfix installed.
    Secondly, is your machine called When setting up an MX record, it has to contain the true fully qualified domain name of the mailserver, or be correctly aliased.
    In order for dnsstuuf or pingability or any other service to be able to check your domain, the DNS records must be correct, so thats the place for you to start.
  5. chuckl

    chuckl New Member

    Just to clarify that a bit, if you create a DNS entry for, it would look like this: MX 10

    N.B. the final '.' on the name is important.

    meaning that the mail server has a priority of 10. The server to which mail is ultimately delivered, i.e. that one, should have the lowest numbered priority.

    Matching that should be a DNS entry for that machine e.g. A

    which tells the world where to find that machine. SImilarly, at some stage you should probably add an SPF record for the domain, defining the sending mail servers, or very little will get through.

    Hope that helps,
  6. Ralle

    Ralle New Member

    No I did not. I will look at the guides now.
    I have a subdomain: which is an A record linking to the same servers IP.
    They cannot check my mail server.

    I might want to tell you my main problem.
    My problem is that emails sent from my server are not received by hotmail and many others.
    I have only succeeded to actually receive an email using gmail.
    I have an SPF record and it fixed it so mails are not spam for gmail. But it's all still blocked from hotmail.

    I have hosting with Layeredtech. The ReverseDNS should be set up correctly, I have SPF record, MX record. So the only thing that comes to my mind is that hotmail tries to contact my mail server to check if my server is valid.
  7. chuckl

    chuckl New Member

    That is almost certainly your problem. Normally in hosted environments, the hosting co mail servers do all the mail sending, and all you do is pass the mail to their servers. MX records are set up accordingly. In fact many places actively block the SMTP ports to prevent mail being sent directly.

    While you may have an A record pointing at your server, does your server respond to mail connections as

    I'm sure hotmail et al are receiving the mail, but they are fairly well known for deleting any mail they feel is 'suspicious'.
  8. Ralle

    Ralle New Member

    Well I guess not. Else pingability would notice it.

    Anyway, I am going to post a layeredtech support ticket about email sending.


    Okay, I have had contact with LayeredTech. They say I am 100% managed. So they aren't blocking anything.
    Last edited: Sep 5, 2007
  9. falko

    falko Super Moderator ISPConfig Developer

  10. Ralle

    Ralle New Member

    I got it working!
    It was my MX record. I linked to but should link to

    Thanks for your help all!
  11. chuckl

    chuckl New Member

    Thats great to hear, best feeling around, when the last kludge finally rings the bell.
  12. Ralle

    Ralle New Member

    So I am actually ready to make my own guide (probably for myself) on how to set up a new server.
    I have been into the subjects:
    APC / xcache
    Sendmail (default setup)
    Getting mail to work.

    Anyway, I am going off-topic. Cya around :)

Share This Page