Sendmail stops working

Discussion in 'Installation/Configuration' started by msp, Apr 9, 2012.

  1. msp

    msp Member

    Hi there,

    After a couple of weeks of not receiving any emails sent from a web-based contact form ("doh!"), sendmail appears to have stopped working.

    From the mail log:
    (!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused, retrying (2)

    Restarting ClamAV fixes the issue:

    /etc/init.d/amavis restart

    ... However I'd like to find out what's causing this, as it has happened a number of times over the last 6 months.

    Is the below related?

    • Under ISPConfig admin interface > Monitor, I get: Your virus protection is OUTDATED!

    • My ClamAV log (as shown in ISPConfig) is empty

    • My FreshClam shows:

      Sun Apr 8 19:25:45 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
      Sun Apr 8 19:25:45 2012 -> bytecode.cld is up to date (version: 168, sigs: 38, f-level: 63, builder: edwin)
      Sun Apr 8 19:25:45 2012 -> WARNING: Current functionality level = 62, recommended = 63
      Sun Apr 8 19:25:45 2012 -> Please check if ClamAV tools are linked against the proper version of libclamav
      Sun Apr 8 19:25:45 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
      Sun Apr 8 19:25:45 2012 -> [LibClamAV] ***********************************************************
      Sun Apr 8 19:25:45 2012 -> [LibClamAV] *** This version of the ClamAV engine is outdated. ***
      Sun Apr 8 19:25:45 2012 -> [LibClamAV] *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
      Sun Apr 8 19:25:45 2012 -> [LibClamAV] ***********************************************************

    Is there something I should be doing?

    Please help!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If you're using ISPConfig 3, you should have Postfix installed instead of Sendmail. What's in your mail log?
     
  3. msp

    msp Member

    Hey Falko, thanks for the response.

    You are right, I didn't mean Sendmail.

    I included the pertinent line from my mail log above, but here it is again:

    (!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused, retrying (2)

    Would you mind weighing-in again?

    Thanks!

    Mat
     
    Last edited: Apr 15, 2012
  4. falko

    falko Super Moderator ISPConfig Developer

    Does /var/run/clamav/clamd.ctl exist? You can check with
    Code:
    ls -la /var/run/clamav/clamd.ctl
    If not, does it exist after
    Code:
    /etc/init.d/amavis restart
    ?
     
  5. msp

    msp Member

    Hi, yes /var/run/clamav/clamd.ctl does exist.

    At the moment mail is sending okay, it's just that it periodically stops. This could be every few months even. The problem is that I don't know of any way of monitoring it.

    The problem is that if messages don't send, I don't get business enquiries, which is my primary income :eek:
     
  6. sjau

    sjau Local Meanie Moderator

    You can use "monit" to monitor the process.
     
  7. msp

    msp Member

    I've installed monit, and looked through its documentation, but my one issue is this:

    It appears monit uses the local mailserver to send email in the event of a problem.

    The thing I need to monitor is the local mailserver itself, as that's the thing that is failing!

    So I don't think using monit will work.

    Can anyone help me? Why do I need to periodically manually restart clamav to make mail send?!
     
  8. falko

    falko Super Moderator ISPConfig Developer

    But you can at least use monit to restart the mail server if it fails.
     

Share This Page