Sendmail-SMTP-AUTH-TLS-Howto

Discussion in 'HOWTO-Related Questions' started by srmiller, Apr 10, 2008.

  1. srmiller

    srmiller New Member

    I've followed the how-to on Sendmail-SMTP-AUTH-TLS-Howto (http://www.howtoforge.com/howto_sendmail_smtp_auth_tls) on a fresh install of Fedora Core 8. All seemed to go just great with no prob's installing/configuring anything, no errors at all, until the end.

    The how-to states:

    To see if SMTP-AUTH and TLS work properly now run the following command:

    telnet localhost 25

    After you have established the connection to your sendmail mail server type

    ehlo localhost

    If you see the lines

    250-STARTTLS

    and

    250-AUTH

    everything is fine.


    My output, however, only shows the following:

    ------------------

    [[email protected] init.d]# /etc/init.d/sendmail start
    Initializing SMTP port. (sendmail)
    [[email protected] init.d]# /usr/sbin/sendmail -d0.1 -bv root
    Version 8.14.2
    Compiled with: DNSMAP LOG MATCHGECOS MILTER MIME7TO8 MIME8TO7
    NAMED_BIND NETINET NETUNIX NEWDB PIPELINING SASLv2 SCANF
    STARTTLS USERDB XDEBUG

    ============ SYSTEM IDENTITY (after readcf) ============
    (short domain name) $w = mail-node-1
    (canonical domain name) $j = mail-node-1.xxxxx.net
    (subdomain name) $m = xxxxx.net
    (node name) $k = mail-node-1.xxxxx.net
    ========================================================

    root... deliverable: mailer local, user root
    [[email protected] init.d]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail-node-1.xxxxx.net ESMTP Exim 4.68 Thu, 10 Apr 2008 15:12:27 -0600
    ehlo localhost
    250-mail-node-1.xxxxx.net Hello localhost.localdomain [127.0.0.1]
    250-SIZE 52428800
    250-PIPELINING
    250-STARTTLS
    250 HELP
    421 mail-node-1.xxxxx.net: SMTP command timeout - closing connection
    Connection closed by foreign host.
    [[email protected] init.d]#

    ------------------

    It does not show the "250-AUTH" as it states in the how-to. Can someone point me to what I may have done wrong?

    Thanks,
    Scott Miller
     
  2. srmiller

    srmiller New Member

    Update

    I have since rebooted the server, and my output is now the following:

    [[email protected] ~]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail-node-1.xxxxx.net ESMTP
    ehlo localhost
    250-mail-node-1.xxxxx.net Hello localhost.localdomain [127.0.0.1], pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-8BITMIME
    250-SIZE 15000000
    250-DSN
    250-ETRN
    250-AUTH LOGIN PLAIN
    250-STARTTLS
    250-DELIVERBY
    250 HELP

    It does not show "250-AUTH" - but does show "250-AUTH LOGIN PLAIN"

    I have tested sending mail through the server, and it accepts both whe the e-mail client is set for SMTP Authentication and when it is NOT set for SMTP Authentication. Is this normal, or did I miss something else?

    Thanks,
    Scott Miller
     
  3. topdog

    topdog Active Member HowtoForge Supporter

    what is in your mynetworks option ?
     
  4. srmiller

    srmiller New Member

    Where sould I find the mynetworks option?

    Scott Miller
     
  5. topdog

    topdog Active Member HowtoForge Supporter

    /etc/postfix/main.cf
     
  6. srmiller

    srmiller New Member

    There was no /etc/postfix/main.cf file in that directory, but there was a main.cf-rpmsave file. I then installed postfix with "yum install postfix" and it installed:

    cyrus-sasl-2.1.22-8.fc8
    postfix-2.4.5-2.fc8

    Now, there's a main.cf file, and the mynetworks portion reads:

    #mynetworks_style = class
    #mynetworks_style = subnet
    #mynetworks_style = host


    #mynetworks = 168.100.189.0/28, 127.0.0.0/8
    #mynetworks = $config_directory/mynetworks
    #mynetworks = hash:/etc/postfix/network_table


    all, however, are comented out.

    I then started postfix "service postfix start". Now, I can not send through it at all. Even after stoping postfix.

    I will start over on the how-to, removing; openssl, cyrusmail and sendmail. Maybe now that postfix is installed it should work?

    Scott Miller
     
  7. falko

    falko Super Moderator ISPConfig Developer

    That's ok.
    Where did you send to? If you send to recipients that are on the same server, then you don't need to authenticate. But if you send to externel email addresses, then you need authentication.
     

Share This Page