sendmail MASQUERADE doing too much

Discussion in 'Server Operation' started by chipsafts, Jan 31, 2008.

  1. chipsafts

    chipsafts New Member

    I have misconfigured MASQUERADE somehow.
    in sendmail.cf I have:
    Code:
    FEATURE(`MASQUERADE_AS',`def.abc')
    MASQUERADE_DOMAIN(`def.abc')dnl
    MASQUERADE_AS(`def.abc')dnl
    FEATURE(masquerade_envelope)dnl
    
    in submit.mc I have:
    Code:
    divert(0)dnl
    include(`/usr/share/sendmail-cf/m4/cf.m4')
    VERSIONID(`linux setup for Red Hat Linux')dnl
    define(`confCF_VERSION', `Submit')dnl
    define(`__OSTYPE__',`')dnl dirty hack to keep proto.m4 from complaining
    define(`_USE_DECNET_SYNTAX_', `1')dnl support DECnet
    define(`confTIME_ZONE', `USE_TZ')dnl
    define(`confDONT_INIT_GROUPS', `True')dnl
    define(`confPID_FILE', `/var/run/sm-client.pid')dnl
    dnl define(`confDIRECT_SUBMISSION_MODIFIERS',`C')
    FEATURE(`use_ct_file')dnl
    dnl
    dnl If you use IPv6 only, change [127.0.0.1] to [IPv6:::1]
    FEATURE(`msp', `[127.0.0.1]')dnl
    define(`confDOMAIN_NAME', `def.abc')dnl
    
    this was done so that the FQDN would not show up when emails were being sent from the server itself.

    problem is that we also do email hosting for domain HIJ.XYZ and all the email being sent from [email protected] is being changed to [email protected], even if the HIJ.XYZ user is not using a terminal on the server for sending the email but a workstation with an email client.

    How do i correct this?
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    There is no sendmail macro like that may be it is the one causing the problem.

    Normally sendmail will only masquerade a domain if it is in MASQUERADE_DOMAIN or FEATURE(`allmasquerade') is turned on.
     
  3. chipsafts

    chipsafts New Member

    ok, i took out

    and changed to
    MASQUERADE_DOMAIN(`abc.def HIJ.XYZ')dnl

    hopefully this will send the emails so that the FQDN does not show as being the From
     

Share This Page