Sendmail doesn't Sort E-Mails

Discussion in 'Server Operation' started by swift, May 29, 2006.

  1. swift

    swift New Member


    I have a problem with my Sendmail server. I can sent E-mails without problems, but i have problems while i'am trying to receive my E-mail.

    Here is a part of errors in my logfiles:

    May 28 15:08:32 84-16-224-163 sensible-mda[24193]: User([email protected]) does not exist!
    May 28 15:08:32 84-16-224-163 sm-mta[24025]: k4NF7kct007115: SYSERR(root): putbody: write error: Broken pipe
    May 28 15:08:32 84-16-224-163 sensible-mda[24194]: User([email protected]) does not exist!
    May 28 15:08:32 84-16-224-163 sensible-mda[24195]: User([email protected]) does not exist!

    Okay, i think that means, the MTA can reveice mails but he can not sort the mails into the correct mail box.

    Any Ideas?
  2. falko

    falko Super Moderator ISPConfig Developer

    Why do you try to accept emails for ebay?

    What happens if you send yourself an email?
    Does it happen for all users?
    What's the output of
    ls -la /etc/mail
  3. swift

    swift New Member

    Hi Falko,

    if i try to send myself an email the mail received on the mailserver. i can read the mail in the mqueue of the server.

    ls -la /etc/mail
    shows a normal output of my sendmail files.

    i have found a answer to all my questions :)
    Stop the mailserver with
    /etc/init.d/sendmail stop
    Copy the working config files from a backup to your /etc/mail directory

    Start the mailserver with
    /etc/init.d/sendmail start
    and it works all fine :)
    I know, it's not the best way to fix this problem. But hey. Why not? The backup is from a date where the mailserver works fine. But, be careful. When you have done a update from your mailserver than you shouldn't load old config files. It will not work.

    So, anyway thanks a lot Falko! :)

Share This Page