Sending/Receiving mail issue

Discussion in 'Installation/Configuration' started by selfxp, Sep 14, 2007.

  1. selfxp

    selfxp New Member

    Hello! I've searched the internet for the last 2 days untill I finally decided to post a thread and hope for help.

    I have three problems:
    1. I can't access the url: http://www.domain.tld:81/webmail/
    error: The requested URL /webmail was not found on this server.

    3. I can't send or receive an email using a pop3 application (Outlook).
    error: The connection to the server has failed. Account:'mail.selfxp.com', Server:'mail.selfxp.com' Protocol SMTP, Port. 25, Sercure(SSL); No, Sochet Error: 10060
    There was a problem loggin onto your mail server. Your Password was rejected. Account: 'mail.selfxp.com' Servce:'mail.selfxp.com' Protocol: POP3, Server Response: 'ERR authorization failed' Port:110, Secure(SSL); No, Server Error:0x800CCC90

    2. I can't access the url: http://www.domain.tld/stats/
    error: 404 Error - File not found!

    Facts:
    - I don't use https.
    - I'm behind a router but I have the ports 81, 25, 110 opened to the SuSE 10.2 machine.
    - SMTP, POP3 Servers are Online
    - Postfix is running and Maildir is checked.

    Thanks in advance!
    Cosmin
     
  2. chuckl

    chuckl New Member

  3. selfxp

    selfxp New Member

    Thanks for answering so fast!

    1. I can access the ISPConfig using internal and external Ip address. Ex. http://ip.addr.of.srv:81 works.
    But http://ip.addr.of.srv:81/webmail/ doesn't.

    2. Authentification is enabled. I use:
    email: selfxp@mydomain.com
    username: web3_selfxp
    password: ****
    pop3: mail.mydomain.com
    smtp: mail.mysomain.com

    And I have created an
    -> A record
    * IP-Adresse: ip.addr.of.srv
    * Hostname: mail

    -> MX record
    * Hostname: [empty]
    * Mailserver:mail.mydomain.com

    Greetings,
    Cosmin
     
  4. catdude

    catdude ISPConfig Developer

    Regarding item 2...

    The way that I've got my ISPConfig set up, the "username" field needs to be the same as the "email" field.

    If that change to your mail client settings doesn't do it, I believe my first step would be to look in /etc/postfix/virtusertable and verify that my e-mail address was mapped there. I would expect you would find a line looking like:
    selfxp@mydomain.com web3_selfxp
    (this is assuming that User Prefix in your system settings is set to [WEBID]_).

    If there is such a line, then you might want to verify POP authentication via telnet. If you execute "telnet <server IP address> 110", you should see something like:

    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    +OK Hello there.

    In response to this, enter:
    USER selfxp@mydomain.com

    This should get you a response of:
    +OK Password required.

    In response to this, enter:
    PASS <your password>

    If the server responds with:
    -ERR Login failed.
    then your password is incorrect. If it responds with:
    +OK logged in.
    your login is correct.

    Once you have the POP server responding with "logged in", the value you used after "USER" is what you want to enter in your email client's "login" field.
     
  5. selfxp

    selfxp New Member

    True, I've found this info:
    selfxp@www.mydomain.com web3_selfxp
    web3_selfxp@www.mydomain.com web3_selfxp
    selfxp@mydomain.com web3_selfxp
    web3_selfxp@mydomain.com web3_selfxp

    The username that logged in successfuly was "web3_selfxp"
    Used it with my email client... but I received the same error :(
    ----
    Again many thanks for the supper fast answer!
    Cosmin
     
  6. catdude

    catdude ISPConfig Developer

    An alternative

    Some mail clients "help" you by auto-editing the user name field. Some of these brain-dead clients assume that if you enter a full e-mail address in the user name field, you really didn't mean to enter the domain portion and strip if off for you.

    Just to see if that's what's happening, instead of using "selfxp@yourdomain.com", use "selfxp%yourdomain.com" (replace the "@" with "%").
     
  7. chuckl

    chuckl New Member

    On the Webmail side, I guess the obvious question is 'Have you installed the Webmail Addon? If you have, you will see it listed under Tools in the IspConfig Panel.
    The mailuser login needs to be ticked in the website config as well I suspect.

    On the Outlook side, the setup I have seen working is to obviously list the server mail incoming and outgoing, user is the ISPconfig user, not the email address, password, and My Server Requires Authentication ticked for both, but Secure Password not ticked.
    For testing, I'd say you're safest using the IP address, or FQDN of the server. You can use cnames, additional A records etc when you have the basic functionality working.
     
  8. selfxp

    selfxp New Member

    It's working! ;)

    Hi and thanks to all for helping me solve the problem.
    It was more complex than I thougt but now it works just fine:
    In order to have my emails work with outlook I had to folow these steps:

    a. Had to set into my goDadday account an
    MX record:
    Host: @
    GoesTo: mail.mydomain.com

    An A record:
    Host: mail
    Points To: MyIpAddress

    b. I've used in order to install IPSConfig the http://www.howtoforge.com/perfect_setup_opensuse_10.2 but on the page six I had to set this variables without the server1 extension:

    postconf -e 'mydomain = mydomain.com'
    postconf -e 'myhostname = $mydomain'

    Maybe there is an workaround but it didn't solve my problem untill I took the "server1" out.

    c. On my outlook configuration I had to use:
    email: selfxp@mydomain.com
    mail: mydomain.com
    smtp: mydomain.com
    username: web3_selfxp

    Now I can send and receive emails. Again thank you all for you help.

    Greetings,
    Cosmin
     

Share This Page