Sending mails: fine > recive: bad

Discussion in 'General' started by Moundy, Jun 17, 2012.

  1. Moundy

    Moundy New Member

    Hi,

    i have another Problem. My user can send mails but not recive. Internal: no problem.

    So if testserver.com is my server, test1@user1.testserver.com can send mails to test2@user2.testserver.com and recive.

    But test1@testserver.com cannot recive from test@gmail.com but test1@testserver.com can send to test@gmail.com and it works fine.

    If i send from test1@gmail.com to test1@testserver.com (ispconfig) i will get after one day this mail:

    and after 2 days the mail appears at test1@testserver.com

    MailWarn:
    Code:
    Jun 17 06:26:15 root postfix/smtpd[15237]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 06:26:15 root postfix/smtpd[15237]: warning: TLS library problem: 15237:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 06:26:15 root postfix/smtpd[15237]: warning: TLS library problem: 15237:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 06:26:15 root postfix/smtpd[15237]: warning: TLS library problem: 15237:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 07:43:01 root postfix/smtpd[20826]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 07:43:01 root postfix/smtpd[20826]: warning: TLS library problem: 20826:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 07:43:01 root postfix/smtpd[20826]: warning: TLS library problem: 20826:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 07:43:01 root postfix/smtpd[20826]: warning: TLS library problem: 20826:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 08:34:01 root postfix/smtpd[21971]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 08:34:01 root postfix/smtpd[21971]: warning: TLS library problem: 21971:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 08:34:01 root postfix/smtpd[21971]: warning: TLS library problem: 21971:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 08:34:01 root postfix/smtpd[21971]: warning: TLS library problem: 21971:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 08:50:15 root postfix/smtpd[20826]: warning: 209.238.180.118: address not listed for hostname jacadogs.com
    Jun 17 08:50:15 root postfix/smtpd[22361]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 08:50:15 root postfix/smtpd[22361]: warning: TLS library problem: 22361:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 08:50:15 root postfix/smtpd[22361]: warning: TLS library problem: 22361:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 08:50:15 root postfix/smtpd[22361]: warning: TLS library problem: 22361:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 08:59:01 root postfix/smtpd[22514]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 08:59:01 root postfix/smtpd[22514]: warning: TLS library problem: 22514:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 08:59:01 root postfix/smtpd[22514]: warning: TLS library problem: 22514:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 08:59:01 root postfix/smtpd[22514]: warning: TLS library problem: 22514:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 10:19:01 root postfix/smtpd[24248]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 10:19:01 root postfix/smtpd[24248]: warning: TLS library problem: 24248:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 10:19:01 root postfix/smtpd[24248]: warning: TLS library problem: 24248:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 10:19:01 root postfix/smtpd[24248]: warning: TLS library problem: 24248:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:18:01 root postfix/smtpd[25711]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:18:01 root postfix/smtpd[25711]: warning: TLS library problem: 25711:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:18:01 root postfix/smtpd[25711]: warning: TLS library problem: 25711:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:18:01 root postfix/smtpd[25711]: warning: TLS library problem: 25711:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:40:21 root postfix/smtpd[26473]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:40:21 root postfix/smtpd[26473]: warning: TLS library problem: 26473:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:40:21 root postfix/smtpd[26473]: warning: TLS library problem: 26473:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:40:21 root postfix/smtpd[26473]: warning: TLS library problem: 26473:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:46:01 root postfix/smtpd[26792]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:46:01 root postfix/smtpd[26792]: warning: TLS library problem: 26792:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:46:01 root postfix/smtpd[26792]: warning: TLS library problem: 26792:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:46:01 root postfix/smtpd[26792]: warning: TLS library problem: 26792:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:47:01 root postfix/smtpd[27031]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:47:01 root postfix/smtpd[27031]: warning: TLS library problem: 27031:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:47:01 root postfix/smtpd[27031]: warning: TLS library problem: 27031:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:47:01 root postfix/smtpd[27031]: warning: TLS library problem: 27031:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:47:43 root postfix/smtpd[27151]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:47:43 root postfix/smtpd[27151]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:47:44 root postfix/smtpd[27151]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:47:44 root postfix/smtpd[27151]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:47:44 root postfix/smtpd[27151]: warning: no entropy for TLS key generation: disabling TLS support
    Jun 17 11:51:01 root postfix/smtpd[27482]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:51:01 root postfix/smtpd[27482]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:51:02 root postfix/smtpd[27482]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:51:02 root postfix/smtpd[27482]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:51:02 root postfix/smtpd[27482]: warning: no entropy for TLS key generation: disabling TLS support
    Jun 17 11:54:44 root postfix/smtpd[27664]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:54:44 root postfix/smtpd[27664]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:54:45 root postfix/smtpd[27664]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:54:45 root postfix/smtpd[27664]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:54:45 root postfix/smtpd[27664]: warning: no entropy for TLS key generation: disabling TLS support
    Jun 17 11:56:02 root postfix/smtpd[27851]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:56:02 root postfix/smtpd[27851]: warning: TLS library problem: 27851:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:56:02 root postfix/smtpd[27851]: warning: TLS library problem: 27851:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:56:02 root postfix/smtpd[27851]: warning: TLS library problem: 27851:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:59:04 root postfix/smtpd[28025]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:59:04 root postfix/smtpd[28025]: warning: TLS library problem: 28025:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:59:04 root postfix/smtpd[28025]: warning: TLS library problem: 28025:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:59:04 root postfix/smtpd[28025]: warning: TLS library problem: 28025:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:59:18 root postfix/smtpd[28138]: warning: cannot get RSA certificate from file /etc/postfix/smtpd.cert: disabling TLS support
    Jun 17 11:59:18 root postfix/smtpd[28138]: warning: TLS library problem: 28138:error:02001002:system library:fopen:No such file or directory:bss_file.c:356:fopen('/etc/postfix/smtpd.cert','r'):
    Jun 17 11:59:18 root postfix/smtpd[28138]: warning: TLS library problem: 28138:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:358:
    Jun 17 11:59:18 root postfix/smtpd[28138]: warning: TLS library problem: 28138:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:722:
    Jun 17 11:59:33 root postfix/smtpd[28251]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:59:33 root postfix/smtpd[28251]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:59:34 root postfix/smtpd[28251]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:59:34 root postfix/smtpd[28251]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:59:34 root postfix/smtpd[28251]: warning: no entropy for TLS key generation: disabling TLS support
    Jun 17 11:59:35 root postfix/smtpd[28263]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:59:35 root postfix/smtpd[28263]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:59:36 root postfix/smtpd[28263]: warning: connect to private/tlsmgr: Connection refused
    Jun 17 11:59:36 root postfix/smtpd[28263]: warning: problem talking to server private/tlsmgr: Connection refused
    Jun 17 11:59:36 root postfix/smtpd[28263]: warning: no entropy for TLS key generation: disabling TLS support
    Mail-queue
    master.cf
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_tls_security_level=encrypt
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #628       inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    #tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    proxywrite unix -       -       n       -       1       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
    	-o smtp_fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    #
    # ====================================================================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    #   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    #  mailbox_transport = lmtp:inet:localhost
    #  virtual_transport = lmtp:inet:localhost
    #
    # ====================================================================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus     unix  -       n       n       -       -       pipe
    #  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ====================================================================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix  -       n       n       -       -       pipe
    #  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ====================================================================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix	-	n	n	-	2	pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    
    
    amavis unix - - - - 2 smtp
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
            -o smtpd_bind_address=127.0.0.1
    
    
    main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = host.test.com
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = host.test.com, localhost, localhost.localdomain
    relayhost = 
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 524288000
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = maildrop
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 471859200
    
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Your cert seems to be broken. You can create a new one like this:

    Code:
    cd /etc/postfix
    openssl req -new -outform PEM -out smtpd.cert -newkey rsa:2048 -nodes -keyout smtpd.key -keyform PEM -days 3650 -x509
    chmod o= smtpd.key
     

Share This Page