Sending Mail Via Postfix Woes

Discussion in 'Installation/Configuration' started by Wsbs9GC, Aug 12, 2012.

  1. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    Hello there. I recently installed ubuntu and ispconfig3 following one of those "perfect server" guides. Everything appeared to go smoothly. However, when connecting to my email accounts on the server through thunderbird, I can receive email but cannot send email. I can send and receive email via the webmail webpage. Postfix is operating on port 587 as I'm on comcast and that's what they require for outgoing mail. The error that I get in /var/log/mail.log:
    and the error that I get in thunderbird:
    I imagine that it's a misconfiguration of dovecot or postfix but as I'm new to linux and system administration, I have no clue regarding how to fix the issue or how to go about troubleshooting the issue.

    Any advice on the issue is greatly appreciated.
     
  2. Sir Henry

    Sir Henry Member

    Is this a server on the internet or your home PC?

    You are not showing any log lines that would be related to an incoming SMTP connection from an external host. On the other hand, are you sure that the name 'mail.domain.com' (replace with your name) gets mapped to your server? You said you can receive mail but there are no connections from outside in your log snippet.
     
  3. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    This is a server on my home LAN. I was running thunderbird from another machine in my LAN. As far as relevant log lines, what log should I post the contents of (or at least a cat | tail )? I'm new to linux and server administration and started this as a hobby so any guidance is greatly appreciated. My mynetworks parameter in /etc/postfix/main.cf which I believe might be relevant is
    I have tried adding 192.168.1.0/24 to this variable thinking that perhaps no auth attempts were made because they never made it to the auth daemon due to being blocked by this parameter and noticed no difference. I have since reverted my addendum.

    What else can I try and what logs should I be looking at?
     
  4. Sir Henry

    Sir Henry Member

    Well, 127.0.0.1 is the localhost address, and 192.168.1.x is your network. In your log there is no login attempt from a 192.168.1.x address.

    What is the address you are trying to connect to from the client PC?
     
  5. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    The LAN IP of my server is 192.168.1.9 and the LAN IP of the machine which I'm running thunderbird on is 192.168.1.7.

    Edit: I think it's also important to know that I am accessing my server through the MX record of my domain, not the lan address of the server machine.
     
    Last edited: Aug 14, 2012
  6. Sir Henry

    Sir Henry Member

    Yes that is important, because it might not resolve correctly. Have you tried to replace the host name with the IP address?
     
  7. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    I just tried your advice and I couldn't log into my email account on the server because it didn't recognize my account name and password combination.

    The output of sudo cat /var/log/mail.log | tail -n 30 after attempting to connect:
     
  8. Sir Henry

    Sir Henry Member

    I did not ask you to change your username, just the mail server address. And do not use SSL/TLS while you are still testing your connection.

    Configure TB with :

    User Name = [email protected] (exactly as set up in ISPConfig, do *not* use the IP address here!)
    Server Name = 192.168.1.9
    Connection Security = NONE
    Authentication Method = Normal Password

    Use the same settings for incoming and outgoing server!

    Then receive and send mail and post your Postfix log again.
     
  9. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    Whoops. I didn't realize I had changed my username. Thanks for pointing that out. I did as you have instructed and here are the results:

    Thunderbird's error:
    cat /var/log/mail.log | tail -n 15:
    The error from Thunderbird comes up immediately after trying to send an email. It appears to have received without error.
     
  10. Sir Henry

    Sir Henry Member

    Ok, receiving seems to work but Postfix is most probably not listening on port 25. Can you post the output of 'postconf -n' please.
     
  11. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    Interesting that it wouldn't be listening on port 25. I did have to set it up for port 587 due to my ISP not allowing mail out on port 25 if that has any relevance. I followed this guide for that http://www.justatheory.com/computers/mail/postfix-and-comcast.html. Here's postconf -n:
     
  12. Sir Henry

    Sir Henry Member

    You are mixing up two things. If you want the Comcast server to relay your mail via its port 587 you do not need to exclude port 25 on your own server.

    Anyway your settings look ok so far, and we need to find out if Postfix is listening at all, and on which port.

    Please post the output of:
    Code:
    netstat -l | grep smtp
    and
    Code:
    netstat -l | grep subm
     
  13. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    Sorry for getting the two mixed up. As I said in my original post, I'm new to linux and server administration so my knowledge on server daemons is limited to say the least.

    netstat -l | grep smtp:
    The output of netstat -l | grep subm was empty.
     
  14. Sir Henry

    Sir Henry Member

    Ok, are you sure you have selected port 25 in Thunderbird, Outgoing Server settings ?

    Alternatively, enable port 587 in Postfix by editing master.cf as described e.g. here.
     
    Last edited: Aug 14, 2012
  15. Wsbs9GC

    Wsbs9GC New Member HowtoForge Supporter

    Wow! Thank you so much Sir Henry! I tried sending on port 25 and it worked and I enabled submission on 587 and it worked there. Thank you for the support. Just one thing, can you summarize what the problem was for me? What I gather is that postfix wasn't able to accept email submissions on port 587 by default so my connections from thunderbird were being dropped by postfix. Is this correct?
     
  16. Sir Henry

    Sir Henry Member

    Well, it's great that I could help you in the end. Better specialists would have spotted your problem straight after your first post; I just needed a bit longer. ;)
     

Share This Page