Sending mail using SMTP does not work (SASL error)

Discussion in 'Installation/Configuration' started by Mannekino, Nov 21, 2010.

  1. Mannekino

    Mannekino New Member

    I'm trying to send e-mail from my server. I followed this tutorial and everything seems to be working fine except for sending e-mail.

    My ISP doesn't allow traffic over port 25 so I put the following line in the master.cf file. I'm running the latest version of Ubuntu with ISPConfig 3.0.3.

    Code:
    2525      inet  n       -       n       -       -       smtpd
    This is the error message I get:

    Code:
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: connect from xxx.direct-adsl.nl[xxx]
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: warning: SASL authentication failure: Password verification failed
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: warning: xxx.direct-adsl.nl[xxx]: SASL PLAIN authentication failed: generic failure
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Nov 21 12:36:44 vm1 postfix/smtpd[2202]: warning: xxx.direct-adsl.nl[xxx]: SASL LOGIN authentication failed: generic failure
    Now I found this topic in where the same problem is addressed. This person said that he uncomment the following line in the master.cf file. I tried the same but it did not work for me, like this.

    Code:
    submission inet n       -       -       -       -       smtpd
    I also tried removing the -c flag in the saslauthd file. Like somebody suggested in that topic. But that also did not work.

    Output of ps aux | grep sasl

    Code:
    root      1510  0.0  0.0  53692   876 ?        Ss   12:03   0:00 /usr/sbin/saslauthd -a pam -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      1512  0.0  0.0  53692   520 ?        S    12:03   0:00 /usr/sbin/saslauthd -a pam -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      1513  0.0  0.0  53692   520 ?        S    12:03   0:00 /usr/sbin/saslauthd -a pam -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      1514  0.0  0.0  53692   520 ?        S    12:03   0:00 /usr/sbin/saslauthd -a pam -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      1515  0.0  0.0  53692   520 ?        S    12:03   0:00 /usr/sbin/saslauthd -a pam -m /var/spool/postfix/var/run/saslauthd -r -n 5
    Anybody got a solution for my problem?

    Thank you for your help.
     
    Last edited: Nov 21, 2010
  2. Mannekino

    Mannekino New Member

: postfix, sasl, smtp

Share This Page