Sending mail to non local host(but the host is on same domain)

Discussion in 'General' started by olasamuelson, Dec 5, 2008.

  1. olasamuelson

    olasamuelson New Member

    Hi all!

    Ispconfig works great.....but sending mail to users in my own domain does not work since the mx for this particular host is remote but ispconfig keep adding it to /etc/postfix/local-host-names.

    - my ispconfig server is ns.domain.se
    - Dns is handled elsewhere, mx points to other server.
    - i have checked "remote mailserver" for site ns.domain.se
    and other sites/subdomains on this domain.

    If i remove all domain.se related entries /etc/postfix/local-host-names
    it works sending mail to domain.se but if i don't.... => "Recipient address rejected: User unknown in local recipient table;"

    ispconfig keeps adding to /etc/postfix/local-host-names and it seems that
    other mail failswhen removing some entries from the file.

    in /etc/hosts: 127.0.0.1 localhost.localdomain localhost only

    in /etc/postfix/local-host-names:

    localhost
    ns.domain.se (the site use external mail)
    localhost.ns.domain.se
    localhost.domain.se
    localhost.localdomain
    www.somedomain1.se (the site use internal mail)
    www.somedomain2.se (the site use internal mail)
    www.somedomain3.se (the site use internal mail)

    Relaying from my own subnet is allowed through $mynetworks.

    I must be missing something trivial no?

    Thank you.
     
  2. olasamuelson

    olasamuelson New Member

    forgot. i am running 2.2.23 on fc8
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Set mailserver to external in the settings of the website AND the co-domain in ispconfig.
     
  4. olasamuelson

    olasamuelson New Member

    Hi! Double checked. No co-domains anywhere BUT i have several subdomains
    such as

    d1.domain.se
    d2.domain.se
    test.domain.se

    etc.

    They are all set to external mailserver.

    Still in local-host-names
    ns.domain.se appears. Granted it IS the name of this host and it is a host in the domain.se but mail should be handled elsewhere.

    The other subdmomains of this domain does not appear in local-host-names so i guess that works. It seems it appears just because it is the actual hostname of this ispconfig server. i.e
    "# hostname"
    gives
    "ns.domain.se"

    More to check?
    Thanks!
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That is the problem. You should use another domain for the hostname, a domain that you don't use for web sites and emails.
     
  6. olasamuelson

    olasamuelson New Member

    Too bad. It is a perfectly logical setup.

    No way to configure postfix to force all mails for domain.se to external mail regardless of everything else?

    Thanks.
     
  7. Norman

    Norman Member

    It's possible if you fiddle with external mailserver settings for all your co-domains and the actual site.
     
  8. patrick3853

    patrick3853 New Member

    I am having the same problem. I tried setting the mailserver to external (co-domains as well), but then I get Relay Access Denied when I try to send an email to any domain hosted at our server. Is there not any way to keep ISPConfig from writing certain domains to the local-host-names file?
     
    Last edited: Dec 11, 2008
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, set them to external mailserver :) Thats why this funtion exists.

    But what you missed most likely is to enable smtp authentication in your email client.
     
  10. olasamuelson

    olasamuelson New Member

    well as i know now that only works if your actual server hostname is NOT in the same domain as the external mailserver. Because if it is...it will turn up in local-host-names no matter what. sorry. could be fixed by either changing hostname or configuring postfix manually...i don't know enough to do the latter. ideas?
     
  11. patrick3853

    patrick3853 New Member

    Okay, i was misunderstanding exactly what setting mailserver to external does. I now see that keeps domains from being written to local-host-names.

    This solved the problem if I use roundcube (installed through ISPConfig). However, if I check "My Server Requires SMTP Authentication" in Outlook, I keep getting a pop up for the username/password everytime I do a send/receive. I don't get this if I don't check the SMTP Authentication box, but then I get a relay access denied everytime I try to send email. Is this an issue with the ISP or some setting on my server?

    This is only the second server I have set up, so please forgive me if I'm just overlooking something obvious.

    Thanks!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when this happens?
     
  13. patrick3853

    patrick3853 New Member

    Dec 11 17:59:34 webserver pop3d: LOGOUT, user=bilmar, ip=[::ffff:74.41.39.46], port=[51470], top=0, retr=0, rcvd=12, sent=39, time=0
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: warning: cannot get certificate from file /etc/postfix/sll/smtpd.crt
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: warning: TLS library problem: 32094:error:02001002:system library:fopen:No such file or dire$
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: warning: TLS library problem: 32094:error:20074002:BIO routines:FILE_CTRL:system lib:bss_fil$
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: warning: TLS library problem: 32094:error:140DC002:SSL routines:SSL_CTX_use_certificate_chai$
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: cannot load RSA certificate and key data
    Dec 11 18:01:30 webserver postfix/smtpd[32094]: connect from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file $
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: SASL authentication failure: no secret in database
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]: SASL NTLM authenticat$
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: SASL authentication failure: realm changed: authentication aborted
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]: SASL DIGEST-MD5 authe$
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file $
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or di$
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: warning: static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]: SASL LOGIN authentica$
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: lost connection after AUTH from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]
    Dec 11 18:01:31 webserver postfix/smtpd[32094]: disconnect from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a configuration problem with your sasl installation. Please redo the email installation steps described in the perfect setup guide for your linux distribution.
     
  15. patrick3853

    patrick3853 New Member

    I ran "apt-get purge postfix libsasl2-2 sasl2-bin libsasl2-modules procmail", then followed the steps on page 5 of The perfect Server for Ubuntu 8.10 (Postfix With SMTP-AUTH And TLS). I created a test site in ispconfig and set up an email account, but now I can't log in to roundcube or send/receive in Outlook. I keep getting authentication failure. Here is what the log says.

    Dec 12 02:24:04 webserver postfix/smtpd[11924]: connect from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]

    Dec 12 02:24:05 webserver postfix/smtpd[11924]: warning: static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]: SASL LOGIN authentication failed: authentication failure

    Dec 12 02:24:05 webserver postfix/smtpd[11924]: lost connection after AUTH from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]

    Dec 12 02:24:05 webserver postfix/smtpd[11924]: disconnect from static-74-41-39-46.dsl1.ckvl.tn.frontiernet.net[74.41.39.46]
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this looks better. What did you use as username to authenticate? The username in ISPConfig has the format web[ID]_username.

    Are you able to connect to the server with pop3 with the same username and password?
     
  17. patrick3853

    patrick3853 New Member

    I've disable the webID_ prefix, so the username should just be whatever i set it to. This is how it was working before I reinstalled postfix. I can still log into roundcube with email accounts that were set up before the reinstall, but it seems that it's not picking up any accounts I've added since then.
     
  18. patrick3853

    patrick3853 New Member

    pop3 is the same as roundcube. it works with accounts setup before reinstalling postfix but not after
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the new users listed in /etc/passwd ?
     
  20. patrick3853

    patrick3853 New Member

    Yes, they also show up in /etc/postfix/virtusertable
     

Share This Page