Sending email with my php script

Discussion in 'Installation/Configuration' started by jhd, Nov 19, 2007.

  1. jhd

    jhd New Member

    when i try to send an email to contact@sexyflash.org using php mail function i have this

    Code:
    Nov 19 14:20:41 localhost postfix/master[9308]: daemon started -- version 2.1.5
    Nov 19 15:32:34 localhost postfix/pickup[9310]: 68A7586C0C1: uid=33 from=<www-data>
    Nov 19 15:32:34 localhost postfix/cleanup[13247]: 68A7586C0C1: message-id=<20071119143234.68A7586C0C1@localhost.localdomain>
    Nov 19 15:32:34 localhost postfix/qmgr[9311]: 68A7586C0C1: from=<www-data@servarena.com>, size=1398, nrcpt=1 (queue active)
    Nov 19 15:32:34 localhost postfix/smtp[13249]: 68A7586C0C1: to=<sexyflash@servarena.com>, orig_to=<contact@sexyflash.org>, relay=redirect.ovh.net[213.186.33.5], delay=0, status=bounced (host redirect.ovh.net[213.186.33.5] said: 550 sorry, no mailbox here by that name (#5.1.1) (in reply to RCPT TO command))
    Nov 19 15:32:34 localhost postfix/cleanup[13247]: BD88A86C0C3: message-id=<20071119143234.BD88A86C0C3@localhost.localdomain>
    Nov 19 15:32:34 localhost postfix/qmgr[9311]: BD88A86C0C3: from=<>, size=3400, nrcpt=1 (queue active)
    Nov 19 15:32:34 localhost postfix/qmgr[9311]: 68A7586C0C1: removed
    Nov 19 15:32:35 localhost postfix/smtp[13249]: BD88A86C0C3: to=<www-data@servarena.com>, relay=redirect.ovh.net[213.186.33.5], delay=1, status=bounced (host redirect.ovh.net[213.186.33.5] said: 550 sorry, no mailbox here by that name (#5.1.1) (in reply to RCPT TO command))
    Nov 19 15:32:35 localhost postfix/qmgr[9311]: BD88A86C0C3: removed
    
    
    I don t know how to fix :/
     
  2. csarlee

    csarlee New Member

    Hi,

    It seems to me that the email address is incorrect, it says no mailbox there by that name. Try to send a mail to you own mail address the see what's happening

    Csarlee
     
  3. jhd

    jhd New Member

  4. jhd

    jhd New Member

    I don t want to use local webmail i prefer to use my registar mx servers that s why i don t set mx dns when i create my website on ispconfig.


    When i send the mail using php mail() function i have all these error and it perturbs me :/

    Please someone can help me ?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you have set mailserver to external in the website sexyflash.org AND all co-domains of this site!
     
  6. jhd

    jhd New Member

    Create MX-DNS isn t checked and in option, Mailserver is set to Mailserver Distant.


    I don t understand why it don t work :(
     
  7. chuckl

    chuckl New Member

    You are not sending mail to contact@sexyflash.org, you are sending mail to sexflash@servarena.com.
     
  8. jhd

    jhd New Member

    Now i have this but i dont receive the mail

    Code:
    Nov 20 12:37:37 localhost postfix/cleanup[6402]: 74B4086C0CF: message-id=<20071120113737.74B4086C0CF@localhost.localdomain>
    Nov 20 12:37:37 localhost postfix/qmgr[2275]: 74B4086C0CF: from=<www-data@servarena.com>, size=1418, nrcpt=1 (queue active)
    Nov 20 12:37:37 localhost postfix/local[6404]: warning: database /etc/aliases.db is older than source file /etc/aliases
    Nov 20 12:37:37 localhost postfix/pickup[2274]: 8C08886C0D0: uid=10002 from=<sexyflash>
    Nov 20 12:37:37 localhost postfix/cleanup[6402]: 8C08886C0D0: message-id=<20071120113737.8C08886C0D0@localhost.localdomain>
    Nov 20 12:37:37 localhost postfix/local[6404]: 74B4086C0CF: to=<sexyflash@servarena.com>, orig_to=<contact@sexyflash.org>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 20 12:37:37 localhost postfix/qmgr[2275]: 74B4086C0CF: removed
    Nov 20 12:37:37 localhost postfix/qmgr[2275]: 8C08886C0D0: from=<sexyflash@servarena.com>, size=366, nrcpt=1 (queue active)
    Nov 20 12:37:37 localhost postfix/local[6404]: 8C08886C0D0: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Nov 20 12:37:37 localhost postfix/qmgr[2275]: 8C08886C0D0: removed
    
     
  9. falko

    falko Super Moderator ISPConfig Developer

  10. jhd

    jhd New Member

  11. falko

    falko Super Moderator ISPConfig Developer

    Is there a user sexyflash on your server? What's the output of
    Code:
    grep sexyflash /etc/passwd
    ?
     
  12. jhd

    jhd New Member

    sexyflash:x:10002:10003:JHD:/home/www/web3:/bin/false
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Ok, so mails to contact@sexyflash.org are sent to a remote server (q1.netfirms.com), but that server doesn't know that mail account.

    What's the output of
    Code:
    grep contact@sexyflash.org /etc/postfix/virtusertable
    ?
     
  14. jhd

    jhd New Member

  15. falko

    falko Super Moderator ISPConfig Developer

    This means that mails for contact@sexyflash.org stay on the server instead of being sent to the actual mailserver for sexyflash.org. Please go to the sexyflash.org domain in ISPConfig (probably on the Co-Domains tab) and set mailserver to external.
     
  16. jhd

    jhd New Member

    it is already set to external :(
     
  17. falko

    falko Super Moderator ISPConfig Developer

    sexyflash.org, or rather www.sexyflash.org? This is a difference.
     
  18. jhd

    jhd New Member

    I have this

    [​IMG]


    What i must to do know ?
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    You must set the co-domain to external mailserver too, not only the website!
     
  20. jhd

    jhd New Member

    what is co-domain ? where can i modified it
     

Share This Page