Sending email problem Bellsouth

Discussion in 'Installation/Configuration' started by cwtudor, Jul 22, 2008.

  1. cwtudor

    cwtudor New Member

    I have a new installation everything works great except sending mail. My ISP is Bell South, I’ve tried the opt out port 25 though their web site have yet to get a response. I also tried to use the post bybagpiperdude90

    relayhost = mail.bellsouth.net
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

    and then also made the sasl_passwd file, with this inside it:

    mail.bellsouth.net username:password

    but, mail will not go thur.

    I telnet mail.bellsouth.net and get this

    server1:~# telnet mail.bellsouth.net 25
    Trying 204.127.217.17...
    Connected to mail.bellsouth.net.
    Escape character is '^]'.
    220 isp.att.net - Maillennium ESMTP/MULTIBOX frfwmhc01 #42
    ehlo
    501 missing fully qualified domain name
    quit
    221 isp.att.net
    Connection closed by foreign host.
    server1:~#

    here is my mail.cf

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    #append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = server1.ctudor.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.ctudor.com, localhost.ctudor.com, , localhost
    relayhost = mail.bellsouth.net
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    #smtp_sasl_security_options =



    mail log

    Jul 22 08:42:27 server1 postfix/smtp[4806]: fatal: open database /etc/postfix/sasl_passwd.db: No such file or directory
    Jul 22 08:42:28 server1 postfix/master[2920]: warning: process /usr/lib/postfix/smtp pid 4806 exit status 1
    Jul 22 08:42:28 server1 postfix/master[2920]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling

    By the way I tryied to clear the queue with this
    postsuper -d ALL deferred
    did not seem to work

    Can you help Thanks
     
  2. catdude

    catdude ISPConfig Developer ISPConfig Developer

    I can't help much with the smartrelay configuration. What I can help with (maybe) is the telnet testing.

    It looks like you might need to specify a host name on the "helo" line. I can't test that right now with bellsouth's servers - I get "telnet: Unable to connect to remote host: No route to host".

    If you aren't familiar with authsmtp testing via telnet, there's info available at http://www.raiden.net/?aid=200
     
  3. cwtudor

    cwtudor New Member

    Network is unreachable (port 25)

    Catdude thanks for the help.

    new telnet test

    server1:~# telnet mail.bellsouth.net 25
    Trying 204.127.217.17...
    Connected to mail.bellsouth.net.
    Escape character is '^]'.
    220 isp.att.net - Maillennium ESMTP/MULTIBOX frfwmhc01 #244
    helo mail.bellsouth.net
    250 isp.att.net
    mail from cwtudor@yahoo.com
    250 ok
    RCPT TO:cwtudor@yahoo.com
    250 ok; [simple] forward to <cwtudor@yahoo.com>
    data
    354 ok
    test mail
    .
    250 ok ; id=20080723011239H0100mcgk7e
    quit
    221 isp.att.net
    Connection closed by foreign host.
    server1:~#


    header from yahoo
    From nobody Tue Jul 22 18:14:51 2008
    Return-Path: <cwtudor@yahoo.com>
    Authentication-Results: mta342.mail.mud.yahoo.com from=; domainkeys=neutral (no sig)
    Received: from 204.127.217.101 (EHLO fmailhost01.isp.att.net) (204.127.217.101) by mta342.mail.mud.yahoo.com with SMTP; Tue, 22 Jul 2008 18:14:51 -0700
    Date: Wed, 23 Jul 2008 01:14:51 +0000 (GMT)
    Received: from mail.bellsouth.net (adsl-074-185-038-192.sip.shv.bellsouth.net[74.185.38.192]) by isp.att.net (frfwmhc01) with SMTP id <20080723011239H0100mcgk7e>; Wed, 23 Jul 2008 01:14:18 +0000 test mail
    Content-Length: 0





    This tells me I do not need username and password authentifition so I remove those lines from main.cf

    new mail log


    Jul 22 21:35:57 server1 postfix/smtp[3251]: connect to mx01.mail.bellsouth.net[205.152.58.33]: Connection timed out (port 25)
    Jul 22 21:35:57 server1 postfix/smtp[3251]: connect to mx00.mail.bellsouth.net[205.152.58.32]: No route to host (port 25)
    Jul 22 21:35:57 server1 postfix/smtp[3251]: 574931F84C3: to=<cwtudor@yahoo.com>, relay=none, delay=30, delays=0.12/0.03/30/0, dsn=4.4.1, status=deferred (connect to mx00.mail.bellsouth.net[205.152.58.32]: No route to host)

    OK more information

    no mx record

    server1:~# dig mx webmail.ctudor.com

    ; <<>> DiG 9.3.4-P1.1 <<>> mx webmail.ctudor.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40433
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;webmail.ctudor.com. IN MX

    ;; AUTHORITY SECTION:
    ctudor.com. 3600 IN SOA ns1.yourhostingaccount.com. admin.yourhostingaccount.com. 2008071881 10800 3600 604800 3600

    ;; Query time: 78 msec
    ;; SERVER: 192.168.1.254#53(192.168.1.254)
    ;; WHEN: Tue Jul 22 21:59:04 2008
    ;; MSG SIZE rcvd: 101

    server1:~#

    I hate to ask before I look, but how do I make this record
     
    Last edited: Jul 23, 2008
  4. catdude

    catdude ISPConfig Developer ISPConfig Developer

    It might help to connect to port 587 instead of port 25, and user your auth credentials. Or it might not - yesterday when I tried to do a telnet test to port 485 on BellSouth's servers I got a route error.

    When you created your domain, did you check the "Create DNS" and "Create DNS-MX" boxes? If so, I think it should have created your MX record.
     
    Last edited: Jul 23, 2008
  5. cwtudor

    cwtudor New Member

    Still not working

    I don't know, tried everthing. Now I'm getting these errors.

    Jul 23 20:52:59 server1 postfix/smtp[30404]: fatal: open database /etc/postfix/sasl_passwd.db: Invalid argument

    the text in the sasl_passwd.db file is simple "[mail.bellsouth.net] xxxxxxx@bellsouth.net:xxxxxxx
    but there is something there postfix doesn't like. also get this error

    Jul 23 20:53:00 server1 postfix/master[25433]: warning: process /usr/lib/postfix/smtp pid 30404 exit status 1
    Jul 23 20:53:00 server1 postfix/master[25433]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling

    I have no idea.


    The wost thing just happen.............I fixed it.......I just don't know what I did

    I redid the sasl_passwd.db file, it had an extra line at the end and a tab between the host and user name removed those and now it works. I don't know could that be it or did I do something else I can't remember.... Anyway thanks so much for the help A very happy Charlie
     
    Last edited: Jul 24, 2008

Share This Page