Send mails via telnet on minimalistic linux - any help appreciated!

Discussion in 'Server Operation' started by nurunet, Oct 14, 2008.

  1. nurunet

    nurunet New Member

    Hi there!

    I am new to this forum and don't know much about Linux, so please be kind. I tried the search function, but either I didn't know what exactly to search for or there are no topics to help me. Anyway...

    I've recently bought a NAS (Conceptronic CH3SNAS), that runs a minimalistic Linux by default. With a special script (fun_plug), it can be turned from a black box into a white box, allowing Telnet/SSH access, the installation of packages etc. This works pretty fine, except for one thing I simply couldn't accomplish:

    I want to start smartd on boot (which I guess should be fairly easy, I know how to theoretically do that) and send smartd reports via email. This way I could monitor my HDD health without having to log on all the time.

    I do not know what Linux is running on the box, I think there's something called Busybox but I'm not sure whether that is a distribution. I installed all available packages (I think they're listed here:, including mailx and esmtp. In /ffp/bin (/ffp is the main directory of the fun_plug installation) there is a file "sendmail" too.

    I read all the documentations and man pages, but that stuff is far too advanced for me. :-( All I want to do is to set up smartd to send me mail reports about special occurrences. While I think I can handle the smartd.conf syntax, esmtp seems out of reach.

    This essentially is what I have in smartd.conf:

    /dev/sda -d marvell -m [email protected] -M exec /ffp/bin/esmtp -M test
    /dev/sdb -d marvell -m [email protected] -M exec /ffp/bin/esmtp -M test
    When running smartd, this is what I get (the interesting part at least):

    My esmtprc looks like this:

    hostname =
    username = "[email protected]"
    password = "myPass"
    force sender = "NAS Admin"
    mda "/ffp/bin/procmail -d %T"
    procmail in /ffp/etc looks like this:

    # Please check if all the paths in PATH are reachable,
    # remove the ones that are not.
    MAILDIR=/ffp/mail # You'd better make sure it exists
    I guess I'm doing a lot of things wrong here, as I don't really know what I am doing at all. Can anyone help me fix this mess? If you need any further info, please tell me. If I could finish smartd config, I'd be ready to use the CH3SNAS productively.

  2. MaryG

    MaryG New Member

    Sending mail under NAS/ffp

    Ben/nurunet: your questions are very interesting and relevant. I have many of the same questions.

    Have you received anwers to your questions (or discovered them by yourself), and can you post them?


  3. nurunet

    nurunet New Member

    Hey Mary,

    I am very sorry - I have to disappoint you. I never solved the problem and just stuck to checking the SMART status manually from time to time. :-(

    All the best,

Share This Page