Send mail but don't receive

Discussion in 'Installation/Configuration' started by domenico, Jan 24, 2006.

  1. domenico

    domenico New Member

    Hi,

    I installed ispconfig on Fedora core 4 with Perfectsetup instructions and
    I've got a problem where my mail server can't receive mail but can send it.

    A look at maillog show those lines

    Jan 21 08:56:13 sele postfix/smtpd[3411]: connect from
    smtp6.libero.it[193.70.192.59]
    Jan 21 08:56:13 sele postfix/smtpd[3411]: B7C6459EA87:
    client=smtp6.libero.it[193.70.192.59]
    Jan 21 08:56:13 sele postfix/cleanup[3418]: B7C6459EA87:
    message-id=<ITFNDL$[email protected]>
    Jan 21 08:56:13 sele postfix/qmgr[2844]: B7C6459EA87:
    from=<[email protected]>, size=1225, nrcpt=1 (queue active)
    Jan 21 08:56:13 sele postfix/local[3419]: B7C6459EA87:
    to=<[email protected]>, orig_to=<[email protected]>, relay=local,
    delay=0, status=sent (delivered to mailbox)
    Jan 21 08:56:13 sele postfix/qmgr[2844]: B7C6459EA87: removed
    Jan 21 08:56:18 sele postfix/smtpd[3411]: disconnect from
    smtp6.libero.it[193.70.192.59]

    in the main.cf I have the lines

    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    unknown_local_recipient_reject_code = 550
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.2/samples
    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions =
    permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_alias_domains = itisvarese.it
    virtual_alias_maps = hash:/etc/postfix/virtusertable

    and the virtusertable has the line

    [email protected] info

    What is wrong?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The mail does got delivered to the root user. Your main.cf file does not look like it was modified by the ISPConfig installer. Did you got any errors during installation?

    In main.cf the following line is missing:

    mydestination = /etc/postfix/local-host-names
     
  3. domenico

    domenico New Member

    Yes,
    I changed manually the entry in main .cf:
    virtual_alias_domain with mydestination without obtain results.
    The fact is that the mail is delivered in the /var/mail/root mailbox but I expect it in /home/www/www.itisvarese.it/user/info/Maildir
    I proved to set home_mailbox = Maildir/ in main.cf without results
    Tanks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked the maildir Checkbox in ISPConfig under management > Server > settings on the mail tab? have you installed dovecot or courier as pop3 and imap daemon?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please check /etc/aliases if mails for info are redirected to root.
     
  6. domenico

    domenico New Member

    Ok Falko,
    I changed /etc/aliases and effectively now there is no more redirect and the received mail is putted into /var/mail/info file.
    Ok Till,
    I changed ISPConfig under management > Server > settings on the mail tab by checking Maildir box and now the received mail is putted into /home/www/www.itisvarese.it/user/info/maildir/new

    It remain that I can send correctly mail from squirrelmail but don't see received mail in INBOX of squirremail, I think some process must move mail from /home/www/www.itisvarese.it/user/info/maildir/new to /home/www/www.itisvarese.it/user/info/INBOX but the INBOX file does not exist so what is wrong ?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Which POP3 daemon do you use? Please post the output of
    Code:
    netstat -tap
     
  8. domenico

    domenico New Member

    The services are under xinetd daemon and the package is imap-2002d-3
    actually are actives imap, imaps, ipop3 and pop3s.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Okay, as you posted later that you use the imap package, youhave to uncheck the maildir checkbox again.

    When the mail is delivered to /var/spool/mail/info file, you should be able to fetch it with pop3 and imap. Have you tried a normal mailclient like outlook or thunderbird instead of using the webmail program?
     
  10. domenico

    domenico New Member

    I removed check in the Maildir checkbox of ISPConfig, restart postfix and now everything work fine.
    Tanks Till and Falko.
     

Share This Page