'Send customer information' not working

Discussion in 'ISPConfig 3 Priority Support' started by philgardner, Jul 4, 2018.

  1. philgardner

    philgardner Member HowtoForge Supporter

    Ubuntu server 18.04
    ISPConfig 3.1.12 (recently migrated from version 3.0.5.4p9)

    This morning I set up a Client Circle consisting of all active clients and resellers. I then sent a message to that Client Circle using the control panel 'Send customer information/Send email message to clients and resellers' form; I used my own email address ([email protected]) as the sender address, an address which naturally is authorized to send mail on the server.

    Everything seemed to work successfully, but the messages have not been delivered. I have checked /var/log/mail.err (empty) and /var/log/mail.log, where I could not find any relevant entries. The normal mail system is working fine.

    Please help me to solve this problem; it's rather urgent (of course I can if necessary send the message manually, though that means collecting the email addresses).
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You should check if you have a valid email address for the admin set under system > interface config. You can also try to set an smtp server there. Other mails that ispconfig is sending like warn messages are working?
     
  3. philgardner

    philgardner Member HowtoForge Supporter

    Yes, I do have a valid admin email set under system > interface config > mail. I'm attaching a screenshot – do those settings look okay?

    I have received a couple of "Mailbox quota ok" messages from ISPConfig on the server, so I suppose warning messages are working.
     

    Attached Files:

  4. philgardner

    philgardner Member HowtoForge Supporter

    Help, please?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I can't say if these values are ok as only you can know it. Personally, I would just use localhost, port 25 and no starttsl and no smtp user as these are not required for sending on localhost. But using them as you did should probably be ok as well.

    And you are sure that you see absolutely no related messages in the mail.log on this server while sending these emails?
     
  6. philgardner

    philgardner Member HowtoForge Supporter

    I changed the system mail settings to localhost, port 25 and no starttsl and no smtp user as you suggested, and sending a test email via the 'Send customer information' form worked. Phew! Thank you.

    I had looked through the mail.log for the relevant time, and also searched for a distinctive email address by using
    cat /var/log/mail.log | grep '<email-address>' – not forgetting to escape the dots. I found nothing.
     

Share This Page