send and receve mail on centos 4.3

Discussion in 'Installation/Configuration' started by tesquenure, Apr 23, 2006.

  1. tesquenure

    tesquenure New Member

    Hi,

    Try to receve/send mail from/to my ISPconfig users.

    Base on CentOS 4.3
    use The Perfect Setup - CentOS 4.3 step by step (make it too time)

    My DNS provide by dyndns.org (Dynamic DNS).
    3 virtuals domaines

    all ISPconfig server work find.

    But i cant send or receve mail.

    I have a router with a DMZ to my CentOS, all ports open
    Firewall on CentOS disable
    Firewall on ISPconfig disable
    Webmail work find, when i send mail, he said every thing is ok
    But i never receved mail to my own mail box.

    When send mail from my own mail box to a user of ISPconfig server
    no bad return, but never receved it.
    ---------------------------
    #:route
    Destination Passerelle Genmask Indic Metric Ref Use Iface
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
    default 192.168.1.20 0.0.0.0 UG 0 0 0 eth0

    (192.168.1.20 adress of my router)

    ----------------------------

    ":dig mx www.me.dyndns.org

    ;; reply from unexpected source: 202.171.64.9#53, expected 192.168.1.20#53
    ;; reply from unexpected source: 202.171.64.9#53, expected 192.168.1.20#53

    ; <<>> DiG 9.2.4 <<>> mx www.me.dyndns.org
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    202.171.64.9 dns of my FAI

    ---------------------------

    now if i do dig from a server who are not on my network

    ; <<>> DiG 9.2.1 <<>> mx www.me.dyndns.org
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31771
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.me.dyndns.org. IN MX

    ;; ANSWER SECTION:
    www.me.dyndns.org. 22003 IN CNAME me.dyndns.org.

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.50#53(192.168.1.50)
    ;; WHEN: Sun Apr 23 14:40:27 2006
    ;; MSG SIZE rcvd: 53

    I read not all but alot off topic.

    And i dont know that is my probleme.

    help are well come ^^

    Regards

    (sorry for my bad english)
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which pop3 / imap daemon do you use?

    If you use courier or dovecot, you will have to activet the maildir checkbox in ISPConfig under management > server > settings on the mail tab.

    Does "dig mx me.dyndns.org" points to me.dyndns.org and me.dyndns.org points to your IP address?
     
  3. tesquenure

    tesquenure New Member

    hi till,

    As perfect_setup_centos_4.3, i use dovecot with actived maildir checkbox

    dig point on my ip adresse
    dig mx point on me.dyndns.org

    Regards
     
  4. tesquenure

    tesquenure New Member

    hi till,

    Is the hostname important at Centos instalation .

    I put "server101" instead of "me.dyndns.org"

    If it's important how can i change it in CentOS and reflect it in ISPconfig.

    Thx
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can change the hostname of your server in the file: /etc/hostname

    Please have a look in your mail.log, if you get any errors there.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Reboot your server afterwards.
     
  7. tesquenure

    tesquenure New Member

    hi till and falko,

    I change my in /etc/sysconfig/network
    hostname=server101 to hostname=me.dyndns.org

    restart

    Now i can receve mail ;)

    but cant send mail

    #vi maillog
    me postfix/smtp[3567]: 943D9181AB: to=<toto@myotherserver.com>, relay=none, delay=1237, status=deferred (Host or domain name not found. Name service error for name=myotherserver.
    com type=MX: Host not found, try again)

    try
    # dig www.myotherserver.com

    ; <<>> DiG 9.2.4 <<>> www.myotherserver.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34931
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.myotherserver.com. IN A

    ;; ANSWER SECTION:
    www.myotherserver.com. 60 IN A www.xxx.yyy.zzz

    ;; Query time: 4 msec
    ;; SERVER: 192.168.1.20#53(192.168.1.20)
    ;; WHEN: Mon Apr 24 19:45:57 2006
    ;; MSG SIZE rcvd: 48

    then

    # dig mx www.myotherserver.com
    ;; reply from unexpected source: 202.171.64.9#53, expected 192.168.1.20#53
    ;; reply from unexpected source: 202.171.64.9#53, expected 192.168.1.20#53

    ; <<>> DiG 9.2.4 <<>> mx www.myotherserver.com
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    thx
     
    Last edited: Apr 24, 2006
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you create DNS records for myotherserver.com? Can you post the real domain name here?
     
  9. tesquenure

    tesquenure New Member

    Hi falko,

    when it try to send mail from ISPconf to tesquenure@msn.com
    i have this

    Apr 25 06:37:48 me postfix/smtp[11809]: 9285B181BF: to=<tesquenure@msn.com>, relay=none, delay=10, status=deferred (Host or domain name not found. Name service error for nam
    e=msn.com type=MX: Host not found, try again)


    # dig mx www.msn.com
    ;; reply from unexpected source: 202.171.64.2#53, expected 192.168.1.20#53
    ;; reply from unexpected source: 202.171.64.2#53, expected 192.168.1.20#53

    ; <<>> DiG 9.2.4 <<>> mx www.msn.com
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    i think, it's not come from msn the problem ^^ and not from www.myotherserver.com (a product server).

    lynx www.msn.com
    and
    lynx www.myotherserver.com

    work find

    i think i cant resolve mx on my ISPconf server

    why ?, i dont know.

    thx

    PS :

    From my product server www.myotherserver.com if i do

    dig mx www.me.dyndns.org
    ; <<>> DiG 9.2.1 <<>> mx www.me.dyndns.org
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29486
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.me.dyndns.org. IN MX

    ;; ANSWER SECTION:
    www.me.dyndns.org. 43200 IN CNAME me.dyndns.org.

    ;; Query time: 3798 msec
    ;; SERVER: 192.168.1.50#53(192.168.1.50)
    ;; WHEN: Tue Apr 25 07:56:02 2006
    ;; MSG SIZE rcvd: 56
     
    Last edited: Apr 24, 2006
  10. tesquenure

    tesquenure New Member

    Hi,

    # dig @202.171.64.2 google.com mx

    ; <<>> DiG 9.2.4 <<>> @202.171.64.2 google.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47010
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;google.com. IN MX

    ;; ANSWER SECTION:
    google.com. 3600 IN MX 10 smtp1.google.com.
    google.com. 3600 IN MX 10 smtp2.google.com.
    google.com. 3600 IN MX 10 smtp3.google.com.
    google.com. 3600 IN MX 10 smtp4.google.com.

    ;; Query time: 252 msec
    ;; SERVER: 202.171.64.2#53(202.171.64.2)
    ;; WHEN: Tue Apr 25 12:47:46 2006
    ;; MSG SIZE rcvd: 116

    But

    ]# dig google.com mx
    ;; reply from unexpected source: 202.171.64.2#53, expected 192.168.1.20#53
    ;; reply from unexpected source: 202.171.64.2#53, expected 192.168.1.20#53

    ; <<>> DiG 9.2.4 <<>> google.com mx
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    im where im do wrong configuration ?
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in your /etc/resolv.conf?
     
  12. tesquenure

    tesquenure New Member

    nameserver 192.168.1.20

    I ad

    nameserver 202.171.64.9 (ISP DNS)
    nameserver 202.171.64.2 (ISP DNS)
    then
    /etc/init.d/postfix restart
    postsuper -r ALL

    all mails are send ;)

    Thx falko
     
    Last edited: Apr 25, 2006

Share This Page