Self DNS / Godaddy

Discussion in 'Installation/Configuration' started by sampson, Apr 29, 2010.

  1. sampson

    sampson New Member

    Hi,

    I ran through the Perfect server setup, Debian/Lenny, and am trying in vain to get DNS working.

    I am registered through Godaddy. I setup the domain to point to ns1.domain.com and ns2.domain.com. I also added glue records that set ns1 and ns2 to my ip address.

    In ipconfig DNS:
    Zone: domain.com
    NS: ns1.domain.com
    Email: mail.domain.com
    Allow transfers: [my ip address]

    Then under that zone added records:
    Code:
    TYPE     NAME                      DATA
    A          domain.com            [my ip address]
    CNAME      www.domain.com    domain.com
    MX        domain.com            mail.domain.com
    NS        domain.com            ns1.domain.com
    NS        domain.com            ns2.domain.com
    
    But now, no external tools (dnscog, dig) indicate that the zone even exists. I cannot access the site (http, ping, traceroute, etc) through the domain name and cant ping the nameservers.

    Any ideas on what I'm doing wrong?

    Thanks.
     
  2. sampson

    sampson New Member

  3. sampson

    sampson New Member

    Trying the settings in the above link do not appear to help.
     
  4. sampson

    sampson New Member

    This is really strange. I can now ping ns1.domain.com and ns2.domain.com, and even get to a "It Works!" page if I visit ns1.domain.com in my browser. However, I can not get to the site via domain.com or www.domain.com.

    Can someone please help me out?
     
  5. charlesrg

    charlesrg New Member

    Dude this is easy to troubleshoot.

    If your server is your own DNS server just use dig


    dig domain.com @localhost

    dig www.domain.com @localhost

    If you want to check an external server for the answer do:

    dig domain.com @8.8.8.8

    Remember that DNS cache's zones, so make sure your server is answering correct and the others will do when the cache expires.

    If you need to check for a A , NS or MX entry use:

    dig domain.com MX @8.8.8.8
     
  6. sampson

    sampson New Member

    Yeah, I was doing all of that. Turns out, it was a silly issue that was preventing things from working: I had opened up port 53 on my firewall, but only TCP. Once I added 53 UDP to the allowed connections everything started working.

    Thanks!
     
: dns

Share This Page