Segmentation fault

Discussion in 'Installation/Configuration' started by CTAPbIu_MABP, Sep 6, 2008.

  1. CTAPbIu_MABP

    CTAPbIu_MABP New Member

    Hi, community

    My computer is running under Fedore9
    Yesterday I turned it off and this morning find out that chmod doesnt work
    It doesnt work fo any file even under root account it just says

    Code:
    [[email protected] ~]$ chmod a+x 1.txt 
    Segmentation fault
    
    even without parametrs it says the same
    Code:
    [[email protected] ~]$ chmod
    Segmentation fault
    
    i tried to scan and repair my file system with e2fsck
    Code:
    [[email protected] ~]$ /sbin/e2fsck -p /dev/sdb1/
    
    but without any changes

    what can be wrong with my system?

    PS sorry for my poor english :(
     
  2. ralic

    ralic New Member

    You need to run fsck as root. Probably best to boot into single-user mode, or even a rescue disk might be needed as the filesystem being checked cannot be checked while mounted. Check all linux partitions except swap. chmod (in /bin) is dynamically linked, so the problem could be in one of the library files (in /lib) which could be on a different partition.

    Your problem could also be caused by some bad RAM. If you find nothing wrong with your disks, try running a memory testing tool such as memtest86+. I'd suggest you run it continuously for nothing less than 24 hours for a reliable test, unless it shows errors sooner than that.
     
  3. CTAPbIu_MABP

    CTAPbIu_MABP New Member

    i did so at first time ;)

    inconclusively :(

    this too :(

    RAM test is OK

    Is there any way to reinstall chmod?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Like ralic I think it's a hardware problem, but it's hard to tell which part it is. Could as well be the mainboard or anything else.
     
  5. CTAPbIu_MABP

    CTAPbIu_MABP New Member

    may be this will help to tel what is the problem

    i dont know what means this line
    but i dont like it
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Does /etc/ld.so.preload exist?
     
  7. CTAPbIu_MABP

    CTAPbIu_MABP New Member

    No it doen't
    but i dont know how to create (generate) new(((
     
  8. ralic

    ralic New Member

    I did the same strace (but on ubuntu). They look very similar. Where yours crashes, mine seems to start doing locale activity.

    Maybe between reboots you have done something that has messed up your locale configuration?

    Can you check your locale setup and see if it is working or broken?
    I'm not a locale expert, but
    Code:
    locale -a
    seems like a useful test to check if it's working.

    I have it too and mine works. Probably not important for this particular problem.
     
  9. CTAPbIu_MABP

    CTAPbIu_MABP New Member

    Code:
    locale -a
    return long list of locales
     
  10. ralic

    ralic New Member

    Ok, probably not that then.

    Sorry, not sure what else to suggest. Maybe someone can help you re-install chmod on fedora...
     

Share This Page