Segmentation Fault while trying to start Apache

Discussion in 'Server Operation' started by vibs_im, Mar 20, 2007.

  1. vibs_im

    vibs_im New Member

    Hi All

    I am using a centOS server and am trying to install Apache 2.0.48 using a tar.gz file .....
    The configure , make and make install commands got executed without any errors , but when i try to start Apache using either $ ./apachectl start or $ service httpd start ... I get the same error " Segmentation Fault $HTTPD -k $ARGV "

    The following is the configure command that I used to install Apache :
    $ ./configure --prefix=/home/new1/httpd/ --enable-rewrite --enable-mods-
    shared=all --enable-logio --enable-deflate --enable-ssl

    Hoping an urgent help .

    Thanks in Advance
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to compile Apache again? If the problem persists, it might be a problem with your RAM.

    Is there a reason why you don't install the CentOS Apache package?
     
  3. vibs_im

    vibs_im New Member

    Hi ..
    yes I have tried to compile Apache many times ... but in vain ... I have put the server on RAM testing ...... and am waiting for it to complete .

    Actually my server environment is supposed to be Apache and PHP with OCI8 support ..... The Apache (2.0.52) is already installed and when I try to compile PHP with OCI8 support it is giving some httpd's apr utility related errors . Also Apache package already installed is without --enable-so which is giving problems ............

    So , I had to reconfigure Apache .............

    Thanks and any further help will be appreciated .
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. vibs_im

    vibs_im New Member

    Problem Solved

    Hi Falko

    I had already gone thru this tutorial .....
    Actually the problem is solved .. :) I tried configuring Apache 2.0.50 instead of 2.0.48 and it was successful I don't know what was the problem with the previous version .... So, my server is now ready with Apache , PHP with oci8 support .

    Thanks a lot anyways
     

Share This Page