Seems nothing monitors rspamd?

Discussion in 'ISPConfig 3 Priority Support' started by Taleman, Aug 31, 2020.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Found this in rspmd log:
    Code:
    2020-08-29 06:26:09 #22564(normal) glib; rspamd_glib_printerr_function: **
    ERROR:/release/rspamd-2.5/src/libserver/async_session.c:229:rspamd_session_remove_event_full: code should not be reached
    
    2020-08-29 06:26:09 #22564(normal) rspamd_crash_sig_handler: caught fatal signal 6(Keskeytetty), pid: 22564, trace:
    2020-08-29 06:26:09 #22564(normal) rspamd_print_crash: 0: 00007F1F1FC38FFF: gsignal()+0xcf
    
    After that e-mails worked only somewhat. Nothing I tried showed me part of rspamd was not running.
    Rebooting host restored service and now it works again.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's possible that rspamd monitoring is not implemented yet.
     
  3. elmacus

    elmacus Active Member HowtoForge Supporter

    I use Monit for Rspamd + Redis. It will try to restart Rspamd if problems.
     

Share This Page