security problem for joomla

Discussion in 'Installation/Configuration' started by Camran, May 7, 2008.

  1. Camran

    Camran New Member

    Hello Friends,

    I have install joomla and it show me that i have to turn on "Magic Quotes GPC" which in ISPConfig i dont know in which file i have to set it on.

    Thanks for your attention.
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Joomla 1.5 comes with an .htaccess file which turns on "Magic Quotes GPC".

    Probably, the use of .htaccess files is not allowed on your server, because of the global configuration within your php.ini file. So to make use of the .htaccess file which comes with Joomla, add the following lines within the Apache directives field for the site within ISPConfig:

    <Directory "/var/www/web1/web">
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    Where "web1" is your own web number as provided by ISPConfig.
    Alternatively, you can change the line:

    magic_quotes_gpc = Off
    into
    magic_quotes_gpc = On

    within your php.ini file.

    If you use php5 as a module, this file can be found within /etc/php5/apache2/php.ini
    If you do so, restart Apache2 afterwards with: /etc/init.d/apache2 restart
     
  3. Camran

    Camran New Member


    "add the following lines within the Apache directives" << Where should i add? i am not much fimilar which ISPConfig configuaraiton
     
  4. Hans

    Hans Moderator ISPConfig Developer

    Within ISPConfig > ISP Manager, in the structure tree click on your web, then go to the tab "Basis" and there you'll find the Apache directives field of that site. Press "Save" Afterwards.
     
  5. Camran

    Camran New Member

    But PHP magic_quotes_gpc setting is `OFF` instead of `ON` again

    I have added
    Code:
    <Directory "/var/www/web9/web">
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    in Apacge directives field of my site but i see the security problem again.
    could you please help me on this issue..

    tanks again
     
  6. Hans

    Hans Moderator ISPConfig Developer

    As i told you before, you can change the line:

    magic_quotes_gpc = Off
    into
    magic_quotes_gpc = On

    within your php.ini file.

    If you use php5 as a module, this file can be found within /etc/php5/apache2/php.ini
    If you do so, restart Apache2 afterwards with: /etc/init.d/apache2 restart
     
  7. Camran

    Camran New Member

    if i dont want to change global configuration

    how can i dont change php.ini any other way i used your first direction but it doesnt work, excuse me if i ask more.:confused:
     
  8. Hans

    Hans Moderator ISPConfig Developer

    Try to add the folowing line within the Apache directives field of the Joomla site within ISPConfig and press save:

    php_flag magic_quotes_gpc on
     
  9. Camran

    Camran New Member

    Thanks

    I just want to say thank you for your help
     
    Last edited: May 12, 2008

Share This Page