Second nameserver cannot connect to the internet.

Discussion in 'Installation/Configuration' started by Showa, Dec 10, 2010.

  1. Showa

    Showa Member HowtoForge Supporter

    Hello to you all,

    I have set up my Centos 5.5 server with ISPConfig 3 as a nameserver and as a router.
    This server has two networkcards eth0 which connects directly to the internet and has the following set up:
    IP 192.168.2.10
    Netmask 255.255.255.0
    Gateway 192.168.2.254.
    The second networkcard connects to a switch for my internal network this has:
    IP 10.0.0.0.10
    Netmask 255.255.255.0
    Gateway 192.168.2.10
    Master nameserver has ip 10.0.0.10
    Slave nameserver has ip 10.0.0.15
    After setting up the router I'm able to connect to the internet with my xp-computer using a static ip-adres
    IP 10.0.0.40
    netmask 255.255.255.0
    gateway 192.168.2.10

    I also would like my secondary nameserver to connect to the internet to use yum etc.
    So I set up eth0 on this Centos 4.8 computer as follows:
    IP 10.0.0.15
    netmask 255.255.255.0
    gateway 192.168.2.10

    Unfortunally I cannot get a connection to the internet on the second nameserver. I can ping the computers in the 10.0.0.x range but I cannot ping 192.168.2.10. Do I also have to make some settings on the IPtables, or is this a problem due to Bind, and do I have to correct my named.conf.

    With kind regards,

    Ad.
     
  2. Showa

    Showa Member HowtoForge Supporter

    This is the named.conf file on the slave:

    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    options {
    listen-on port 53 { any; };
    # listen-on-v6 port 53 { ::1; };
    listen-on-v6 port 53 { 127.0.0.1;10.0.0.10;10.0.0.15;10.0.0.20;10.0.0.30;10.0.0.40;10.0.0.50; };
    directory "/var/named/chroot/var/named";
    dump-file "/var/named/chroot/var/named/data/cache_dump.db";
    statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
    # memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
    allow-query { 127.0.0.1;10.0.0.10;10.0.0.15;10.0.0.20;10.0.0.30;10.0.0.40;10.0.0.50; };
    recursion yes;
    };
    logging {
    channel default_debug {
    file "data/named.run";
    severity dynamic;
    };
    };
    #zone "." IN {
    # type hint;
    # file "named.root";
    #};
    acl "mylan" {
    127/8; 10.0.0.0/24;
    };

    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };

    view "inside" {
    match-clients { "mylan"; };
    recursion yes;

    zone "." IN {
    type hint;
    file "named.root";
    };

    zone "0.0.10.in-addr.arpa" IN {
    type slave;
    file "yourlan.db";
    masters { 10.0.0.10; };
    };

    zone "amtand.nl" {
    type slave;
    file "db.amtand.nl.inside";
    masters { 10.0.0.10; };
    };

    };

    view "outside" {
    match-clients { any; };
    recursion no;

    zone "." IN {
    type hint;
    file "named.root";
    };

    zone "amtand.nl" {
    type slave;
    file "db.amtand.nl.outside";
    allow-transfer { 192.168.2.10; };
    masters { 10.0.0.10; };
    };
    };

    include "/var/named/chroot/etc/rndc.key";
    include "/var/named/chroot/etc/named.conf.local";

    SELinux and firewall options are both disabled.
     
    Last edited: Dec 11, 2010
  3. Showa

    Showa Member HowtoForge Supporter

    Is no bind problem, stopping named has no effect,

    I did a complete reinstall, and also then I wasn't able to connect through the Centos router. Connecting the computer directly to to the gateway, I was only able to connect by DHCP. Using a fixed IP was no succes.

    Using netstat -r there is no gateway with a fixed adress.

    Anybody has a clue?
     
  4. Showa

    Showa Member HowtoForge Supporter

    Problem solved!:D

    The answer was quit simple. I thought the gateway had to point to eth0 which is connected to the internet (this functioned on the windows computers) in my case 192.168.2.10. The solution was putting the gateway at 10.0.0.10 the ip of eth1, and after a network restart I was able to connect to the internet.

    My next task building a samba server for my internal network.

    With kind regards,

    Ad.
     

Share This Page