Second domain cannot receive incoming email

Discussion in 'General' started by ariefaisalz, Apr 18, 2006.

  1. ariefaisalz

    ariefaisalz New Member

    hi,

    i'm a newbie here. I already setup 2 domain using ISPConfig, e.g. www.pristronic.com.my and www.e-markplus.com. The first domain www.pristronic.com.my doesn't have any problems and working. But the second domain have error when receiving email.

    If I sending email from saya@e-markplus.com to user@gmail.com, it's fine. But when I want to reply or to send a new message from user@gmail.com to saya@e-markplus.com, it has a problem:

    This is an automatically generated Delivery Status Notification

    Delivery to the following recipient failed permanently:

    saya@e-markplus.com

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

    But sending and receiving is working between www.pristronic.com.my and www.e-markplus.com.

    What is the solution for this? Thanks.:eek:
     
  2. till

    till Super Moderator

    Please make sure you have a co domain e-markplus.com (with empty host field!) in the website www.e-markplus.com.
     
  3. ariefaisalz

    ariefaisalz New Member

    thanks for your fast reply.

    Ok, the co domain e-markplus.com already registered in the website www.e-markplus.com. But still got the error

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

    when i run dig mx, this is the result

    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63800
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;www.e-markplus.com. IN MX

    ;; ANSWER SECTION:
    www.e-markplus.com. 16984 IN CNAME e-markplus.com.
    e-markplus.com. 16984 IN MX 50 bkpmail.localdns.com
    e-markplus.com. 16984 IN MX 10 mail.e-markplus.com.

    ;; AUTHORITY SECTION:
    e-markplus.com. 103384 IN NS ns10.localdns.com.
    e-markplus.com. 103384 IN NS ns11.localdns.com.

    ;; ADDITIONAL SECTION:
    bkpmail.localdns.com. 85377 IN A 203.115.194.133
    ns10.localdns.com. 84904 IN A 202.75.41.19
    ns11.localdns.com. 7986 IN A 202.190.203.134

    ;; Query time: 16 msec
    ;; SERVER: 161.142.201.17#53(161.142.201.17)
    ;; WHEN: Wed Apr 19 10:06:03 2006
    ;; MSG SIZE rcvd: 190

    How do i solve this problem?
     
  4. till

    till Super Moderator

    The error you encounter comes from your mail transfer agent and is not DNS related.

    Do you have postfix or sendmail installed on the SMTP server of the domain e-markplus.com?
     
  5. ariefaisalz

    ariefaisalz New Member

    i'm using postfix, and the postfix domain is www.pristronic.com.my. I'm adding another domain www.e-markplus.com using ISPconfig control panel.

    This is my main.cf contents:

    onsl2:/etc/postfix # vi main.cf
    #
    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    #virtual_maps = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = onsl2.$mydomain
    program_directory = /usr/lib/postfix
    inet_interfaces = all
    masquerade_domains =
    #mydestination = $myhostname, localhost.$mydomain
    defer_transports =
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = yes
    smtpd_use_tls = yes
    smtp_use_tls = yes
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    mydomain = pristronic.com.my
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_tls_auth_only = no
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names


    And this is local-host-names files:

    localhost
    onsl2.pristronic.com.my
    localhost.onsl2.pristronic.com.my
    localhost.pristronic.com.my
    www.pristronic.com.my
    www.e-markplus.com
    pristronic.com.my
    e-markplus.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    I think that the postfix is using single domain. Is it true? How can i configure it with multiple domain?

    Thanks
     
  6. falko

    falko Super Moderator

    I found this:
    Code:
    dig mx e-markplus.com
    
    ; <<>> DiG 9.2.4 <<>> mx e-markplus.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12561
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;e-markplus.com.                        IN      MX
    
    ;; ANSWER SECTION:
    e-markplus.com.         86400   IN      MX      50 bkpmail.localdns.com.
    e-markplus.com.         86400   IN      MX      10 [B][COLOR="Red"]mail.e-markplus.com[/COLOR][/B].
    
    ;; Query time: 337 msec
    ;; SERVER: 213.133.98.97#53(213.133.98.97)
    ;; WHEN: Wed Apr 19 14:27:02 2006
    ;; MSG SIZE  rcvd: 86
    But mail.e-markplus.com doesn't exist:

    Code:
    dig mail.e-markplus.com
    
    ; <<>> DiG 9.2.4 <<>> mail.e-markplus.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26260
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.e-markplus.com.           IN      A
    
    ;; Query time: 300 msec
    ;; SERVER: 213.133.98.97#53(213.133.98.97)
    ;; WHEN: Wed Apr 19 14:27:17 2006
    ;; MSG SIZE  rcvd: 37
    which means mails for e-markplus.com are delivered to bkpmail.localdns.com which somehow doesn't know how to handle them.
    Please create an A record for mail.e-markplus.com.
     
  7. ariefaisalz

    ariefaisalz New Member

    I have confirmed with my hosting provider, the problem is a dns problems. The have updated the record. So, I I can use the email now. Thanks to you for helping me pointed the error.
     

Share This Page