Screwed up, ticked Letsencrypt box for my domain, now can't get into ISPconfig or website!

Discussion in 'Installation/Configuration' started by biffnix, Feb 11, 2017.

  1. biffnix

    biffnix New Member

    I admit I screwed up. I had enabled letsencrypt SSL certificates automatically using the perfect server guide, and all was well. SSL was updating regularly for months.

    Today, I logged into my ISPconfig console on mydomain and on port 8080, and while I was there, I ticked the checkboxes for my domain titled (I think) use letsencrypt SSL and one other that was related to SSL.

    In my head, I thought it would override the SSL settings I had that were working. Don't know what happened, but now I can't log into ISPconfig, and my website and domain are no longer accessible. I get the error "ERR_CONNECTION_REFUSED" when I try to connect to either my website or ISPconfig (also tied to my domain, but on port 8080).

    How can I get back into ISPconfig and undo my change? Clearly, there's a mismatch between SSL info between ISPconfig, and what my webserver THINKS it should be.

    I'm using Ubunto 16.04, with Apache2, with ISPconfig 3.1.

    I can ssh into my server, and the Dovecot mail server is still receiving mail, although I can't log into the web interface anymore either (mydomain.us/roundcube) due to the connection refused error.

    Thank you for any ideas on how to undo my change so I can get back into ISPconfig and fix my domain is very much appreciated.
     
  2. ahrasis

    ahrasis Active Member

    Most probably apache2 cannot restart/reload. What you may want to do is to log in to your server via ssh and go to /etc/apache2/sites-available and fix the vhost file for the domain you have recently changed. If you have a working backup, use it to replace that domain vhost. Restart apache2 via service apache2 restart. If it still cannot restart, check what is the problem using this command: service apache2 status. Reading the log file may be useful too.
     
  3. biffnix

    biffnix New Member

    I know I have done a backup of ISPconfig before updating in the past. How can I recover that? I'm not sure where to find it, or how to use it to restore to the previous state.

    Here is the result of 'service apache2 status:

    Feb 10 02:23:42 squishbox apache2[1095]: *
    Feb 10 02:23:42 squishbox apache2[1095]: * The apache2 configtest failed.
    Feb 10 02:23:42 squishbox apache2[1095]: Output of config test was:
    Feb 10 02:23:42 squishbox apache2[1095]: apache2: Syntax error on line 219 of /etc/apache2/sites-enabled/000-ispconfig.vhost: /etc/apache2/sites-enabled/000-ispconfig.vhost:9: <VirtualHost> was not closed.
    Feb 10 02:23:42 squishbox apache2[1095]: Action 'configtest' failed.
    Feb 10 02:23:42 squishbox apache2[1095]: The Apache error log may have more info
    Feb 10 02:23:42 squishbox systemd[1]: apache2.service: Control process exited, c
    Feb 10 02:23:42 squishbox systemd[1]: Failed to start LSB: Apache2 web server.
    Feb 10 02:23:42 squishbox systemd[1]: apache2.service: Unit entered failed state
    Feb 10 02:23:42 squishbox systemd[1]: apache2.service: Failed with result 'exit-

    Any help is appreciated. Thanks!
     
  4. biffnix

    biffnix New Member

    I was able to restart Apache2, finally, after backing up my squish.us.vhost file, and my primary vhost (squish.us) came back up. Had an old version, which worked. No such luck with the ispconfig.conf and ispconfig.vhost files, so I'm trying to find a way to get ISPconfig back to a state where I can log in again. Any ideas are appreciated.

    Thanks again, your help put me on the right track. Now just trying to find out how to undo the changes so I can log back in to ISPconfig.
     
  5. ressel

    ressel Member

    How about run update of ispconfig and select reconfigure ??
     
    biffnix likes this.
  6. biffnix

    biffnix New Member

    YES - success! When I was able to get Apache2 to restart by editing my domain.vhost file and restarting Apache2 after a2ensite on the edited squish.us.conf, the ispconfig_update.sh worked! I reset the SSL, and now I can log in again.

    Thanks so much for heading me in the right direction. I really appreciate it.
     
    ahrasis likes this.
  7. ahrasis

    ahrasis Active Member

    That is a good news.

    If you still wish to use LE, make sure you backed up your ssl for your site, then disabled it fully by going to its ssl config, delete them and save. Wait for sometimes as ISPC need time to reconfigure that site. Red button on top of ISPC will dissapear when it's ready. Only after that you proceed to tick SSL and LE button and save. That is for the site other than your server site.

    If you need to change your ISPC server site to use LE, then follow my post in here: https://www.howtoforge.com/communit...cates-into-ispconfig.71055/page-7#post-355116

    All the best.
     

Share This Page