Screen Resolution question

Discussion in 'Desktop Operation' started by kadi, Mar 11, 2008.

  1. kadi

    kadi New Member

    Hello
    I have a small problem with screen resolution, i have OS debain etch 4
    for a while and i use the server for normal operation, i mean not playing
    games or thing like this, anyway my problem is i adjusted the screen
    resolution to 1024X768 and each time i start the server the resolution
    change to 640X480 i don't know why , i have a LCD 17 monitor and a
    regular graphic card 32MB, and then i restart the server again and it
    starts with the right one, i just wonder if there is any solution for this
    problem ?
    Thanks for help in advance:)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs? What's in /etc/X11/xorg.conf?
     
  3. kadi

    kadi New Member

    Thanks again for your hep

    hello mr/Falko
    Thanks for your reply.
    here is the section i think that you want to look at it from x11/xorg.conf:
    Section "Device"
    Identifier "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    Driver "nv"
    BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "Radius-73"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    Monitor "Radius-73"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection
    Concerning the logs no errors .
    the informaion up in the file for the device is right also the monitor, also
    i set screen resolution to 1024 X 768.
    Thanks again
     
  4. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer

    Hi kadi,

    please remove all other resolutions than 1024x768 from your xorg.conf - additionally you can delete depth 1 - 16.

    The corresponding part could look like this:

    Code:
    Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    Monitor "Radius-73"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x768"
    EndSubSection
    EndSection
    After that reboot the system or log out and in again to take the changes effect.

    Best regards,

    Olli
     
  5. kadi

    kadi New Member

    Thanks very much for your help

    Hello Olli
    Thanks it works.
    Thanks very much for your help, i appreciated.:)
     
    Last edited: Mar 13, 2008

Share This Page