Scheduled Backups With Rsyncbackup On Debian Etch question

Discussion in 'HOWTO-Related Questions' started by overdose, Jun 4, 2008.

  1. overdose

    overdose New Member

    Greetings. I have been receiving a very frustrating error while following this tutorial. I was wondering if anyone who has gone through this tutorial has an inclination as to what is going on. I am stumped.

    I am able to successfully test and execute both the manual and weekly backup sets, but not daily! Here is the error it spits at me when i attempt:
    Code:
    localhost:~#rsyncbackup -x /etc/rsyncbackup -vv -d -s daily
    Code:
    PATH DIR:/etc/rsyncbackup/
    LOG DIR:/etc/rsyncbackup/logs
    CONFIG_FILE:/etc/rsyncbackup/config.conf
    SOURCE FILE:/etc/rsyncbackup/sources.conf
    DESTS_FILE:/etc/rsyncbackup/destinations.conf
    BACKUPSET_FILE:/etc/rsyncbackup/backupset.conf
    BACKUPSET:daily
    
    Backup set 1	logs		to		store_logs
    Source          : logs
    Source dir      : [local] /var/log
    Source opts     : 
    Source cond     : true
    Destination     : store_logs
    [COLOR="Red"]Destination dir : [ERROR]: Unknown destination type, should be file or local![/COLOR]
    Destination opts: 
    Destination cond: 
    Config options  : --stats --progress --links --hard-links --times --recursive --perms --owner --group --compress --backup
    Backupset opts  : true
    All options     : --stats --progress --links --hard-links --times --recursive --perms --owner --group --compress --backup   
    All conditions  :  true true
    
    solarnix:/etc/rsyncbackup# nano config.conf 
    solarnix:/etc/rsyncbackup# rsyncbackup -x /etc/rsyncbackup -vv -d -s daily
    PATH DIR:/etc/rsyncbackup/
    LOG DIR:/etc/rsyncbackup/logs
    CONFIG_FILE:/etc/rsyncbackup/config.conf
    SOURCE FILE:/etc/rsyncbackup/sources.conf
    DESTS_FILE:/etc/rsyncbackup/destinations.conf
    BACKUPSET_FILE:/etc/rsyncbackup/backupset.conf
    BACKUPSET:daily
    
    Backup set 1	logs		to		store_logs
    Source          : logs
    Source dir      : [local] /var/log
    Source opts     : 
    Source cond     : true
    Destination     : store_logs
    [COLOR="Red"]Destination dir : [ERROR]: Unknown destination type, should be file or local![/COLOR]
    Destination opts: 
    Destination cond: 
    Config options  : --stats --progress --links --hard-links --times --recursive --perms --owner --group --compress --backup
    Backupset opts  : true
    All options     : --stats --progress --links --hard-links --times --recursive --perms --owner --group --compress --backup   
    All conditions  :  true true
    
    Here are my config files, exactly as they are at the time of error.

    Code:
    /etc/rsyncbackup/config.conf
    Code:
    --stats
    --progress
    --links
    --hard-links
    --times
    --recursive
    --perms
    --owner
    --group
    --compress
    --backup
    
    Code:
    /etc/rsyncbackup/sources.conf
    Code:
    configs|local:/etc|true|
    logs|local:/var/log|true|
    
    Code:
    /etc/rsyncbackup/destinations.conf
    Code:
    store_configs|ssh[key=id_rsa,incremental=7,tag=increment]:root@192.168.0.3:/backups/configs/|/usr/bin/traceroute -m 2 192.168.0.3|--bwlimit=300 --de$
    store_logs|ssh[key=id_rsa,incremental=7,tag=increment]root@192.168.0.3:/backups/logs/|/usr/bin/traceroute -m 2 192.168.0.3|--bwlimit=300 --delete
    store_manual|ssh[key=id_rsa]:root@192.168.0.3:/backups/manual/|/usr/bin/traceroute -m 2 192.168.0.3|
    
    Code:
    /etc/rsyncbackup/backupset.conf
    Code:
    [manual]
    configs,logs|store_manual|true|
    
    [daily]
    logs|store_logs|true|
    
    [weekly]
    configs|store_configs|true|
    
    
    From what I can tell, the errors are telling me that the destination directory does not exist. I have checked and double checked and all destination directories are correct. Any suggestions are greatly appreciated!! :)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you try
    Code:
    [daily]
    configs,logs|store_logs|true|
    instead?
     
  3. PolishFish

    PolishFish New Member

    Just looking over your /etc/rsyncbackup/destinations.conf file, it looks like you missed a colon after the ssh[key=id_rsa,incremental=7,tag=increment] part (compare your first line to your second line).

    After that, you should be good to go.
     

Share This Page