sasld authentication settings

Discussion in 'Installation/Configuration' started by DaddyFix, Oct 26, 2006.

  1. DaddyFix

    DaddyFix New Member

    Hi all,

    Recenty upgraded server to Debian 3.1 (sarge) and ISP 2.2.7. I used the perfect setup walkthough but I opted out from installing the Courier-POP3/Courier-IMAP pgks.

    The prob I am having is that I can't login to the uw-imapd2002edebian server mail using squirrelmail or roundcube. The error I am getting is...
    The IMAP server is reporting that plain text logins are disabled.
    I reviewed my setup and even tried to reinstall using the roundcube/sendmail walkthoughs but then I got an Internal Server Error when pointing to

    My mail.log says
    Oct 26 08:48:14 xxx imapd[2592]: imap service init from
    Oct 26 08:48:17 xxx imapd[2592]: Command stream end of file, while reading line user=xxx []
    When I telnet to port 25 I get the right response too
    ehlo show
    250-SIZE 10240000
    250 8BITMIME
    I don't know where to look next? Pls help.
  2. DaddyFix

    DaddyFix New Member

    OK.. when I try and TELNET to localhost imap I get this.

    Notice it says LOGINDISABLED?

    * OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS LOGINDISABLED] localhost.localdomain IMAP4rev1 2003.339 at Thu, 26 Oct 2006 11:41:54 -0400 (EDT)
  3. DaddyFix

    DaddyFix New Member

    Ok.. Im done...I give up. I have to get this email working..

    If I don't get some kind of help, I guess I will revert to removinging the mail packages and reinstalling them manually without SSL.
  4. jnsc

    jnsc rotaredoM Moderator

    Do you have this file? /etc/

    and does it contain:

    I accept the risk
    set disable-plaintext nil
  5. DaddyFix

    DaddyFix New Member

    Thanks for replying jnsc

    Ok.. I have reinstall all the packages all over again (postfix imap-ssl etc)
    I have rechecked all the perfect setup options.

    And I noticed that SquirrelMail config has a imap Auth optins and changed it to PLAIN which was confusing to me cause I thought plain was plain text ???

    SquirrelMail Config for IMAP Settings
    IMAP Settings
    4.  IMAP Server            : localhost
    5.  IMAP Port              : 143
    6.  Authentication type    : plain
    7.  Secure IMAP (TLS)      : 0
    8.  Server software        : uw
    9.  Delimiter              : /
    B.  Update SMTP Settings   : localhost:25
    H.  Hide IMAP Server Settings
    R   Return to Main Menu
    C   Turn color off
    S   Save data
    Q   Quit
    Command >> 6
    If you have already set the hostname and port number, I can try to
    detect the mechanisms your IMAP server supports.
    I will try to detect CRAM-MD5 and DIGEST-MD5 support.  I can't test
    for "login" or "plain" without knowing a username and password.
    Auto-detecting is optional - you can safely say "n" here.
    Try to detect supported mechanisms? [y/N]:
    What authentication mechanism do you want to use for IMAP connections?
    login - Plaintext. If you can do better, you probably should.
    plain - SASL PLAIN. If you need this, you already know it.
    cram-md5 - Slightly better than plaintext methods.
    digest-md5 - Privacy protection - better than cram-md5.
    If you don't understand or are unsure, you probably want "login"
    login, plain, cram-md5, or digest-md5 [plain]: plain
    Now I can try and login but Squirrelmail keeps saying I have wrong username or password. Yet, I have set up the username.

    I am checking /etc/postfix/aliases now.
  6. DaddyFix

    DaddyFix New Member

    Yikes... no aliases in /etc/postfix? I just moved from mandriva to debian. Ohuh what did I do? :(

    I would prefer not to use Courier-IMAP/Courier-POP3 cause I am used to UW-imap.

    So basically, I'm lost again. I don't know why I can't login. Hmmm.
  7. falko

    falko Super Moderator ISPConfig Developer

    It's /etc/aliases.

Share This Page