saslauthd issues after upgrade

Discussion in 'Installation/Configuration' started by 3DPeruna, May 19, 2009.

  1. 3DPeruna

    3DPeruna New Member

    I just upgraded following: http://www.howtoforge.com/upgrade-ubuntu-7.10-server-to-8.04-lts

    I thought I followed everything to the "t", but I'm getting an error when I try and start the saslauthd daemon - it fails.

    If I do this

    Code:
    saslauthd -a pam  -n 5  -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    
    It works and I can send out locally and through clients (Outlook).

    Here's the output of the shell:

    Code:
    sh -x /etc/init.d/saslauthd start
    Code:
    + NAME=saslauthd
    + DAEMON=/usr/sbin/saslauthd
    + DESC='SASL Authentication Daemon'
    + DEFAULTS=/etc/default/saslauthd
    + PWDIR=/var/run/saslauthd
    + PIDFILE=/var/spool/postfix/var/run/saslauthd/saslauthd.pid
    + test -f /usr/sbin/saslauthd
    + '[' -e /etc/default/saslauthd ']'
    + . /etc/default/saslauthd
    ++ START=yes
    ++ DESC='SASL Authentication Daemon'
    ++ NAME=saslauthd
    ++ MECHANISMS=pam
    ++ MECH_OPTIONS=
    ++ THREADS=5
    ++ OPTIONS='-c -m /var/spool/postfix/var/run/saslauthd -r'
    + '[' yes '!=' yes ']'
    + '[' xpam = x ']'
    + PARAMS=' -a pam'
    + START='--start --quiet --pidfile /var/spool/postfix/var/run/saslauthd/saslauthd.pid --startas /usr/sbin/saslauthd --name saslauthd --  -a pam'
    + case "${1}" in
    + echo -n 'Starting SASL Authentication Daemon: '
    Starting SASL Authentication Daemon: ++ dpkg-statoverride --list /var/run/saslauthd
    + dir='root sasl 710 /var/run/saslauthd'
    + test -z 'root sasl 710 /var/run/saslauthd'
    + createdir root sasl 710 /var/run/saslauthd
    + '[' -d /var/run/saslauthd ']'
    + chown -c -h root:sasl /var/run/saslauthd
    + chmod -c 710 /var/run/saslauthd
    + start-stop-daemon --start --quiet --pidfile /var/spool/postfix/var/run/saslauthd/saslauthd.pid --startas /usr/sbin/saslauthd --name saslauthd -- -a pam
    + start-stop-daemon --test --start --quiet --pidfile /var/spool/postfix/var/run/saslauthd/saslauthd.pid --startas /usr/sbin/saslauthd --name saslauthd -- -a pam
    + echo '(failed).'
    (failed).
    + exit 1
    
    Thoughts?
     
  2. falko

    falko Super Moderator

    What's in /etc/default/saslauthd?
    Any errors in the mail log?
     
  3. 3DPeruna

    3DPeruna New Member

    Code:
    # Settings for saslauthd daemon
    # Please read /usr/share/doc/sasl2-bin/README.Debian for details.
    #
    
    # Should saslauthd run automatically on startup? (default: no)
    START=yes
    
    # Description of this saslauthd instance. Recommended.
    # (suggestion: SASL Authentication Daemon)
    DESC="SASL Authentication Daemon"
    
    # Short name of this saslauthd instance. Strongly recommended.
    # (suggestion: saslauthd)
    NAME="saslauthd"
    
    # Which authentication mechanisms should saslauthd use? (default: pam)
    #
    # Available options in this Debian package:
    # getpwent  -- use the getpwent() library function
    # kerberos5 -- use Kerberos 5
    # pam       -- use PAM
    # rimap     -- use a remote IMAP server
    # shadow    -- use the local shadow password file
    # sasldb    -- use the local sasldb database file
    # ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
    #
    # Only one option may be used at a time. See the saslauthd man page
    # for more information.
    #
    # Example: MECHANISMS="pam"
    MECHANISMS="pam"
    
    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""
    
    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5
    
    # Other options (default: -c -m /var/run/saslauthd)
    # Note: You MUST specify the -m option or saslauthd won't run!
    #
    # See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
    # See the saslauthd man page for general information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    #OPTIONS="-c -m /var/run/saslauthd"
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    
    The mail.err log:

    Code:
    May 18 15:24:20 ohdweb pop3d: authdaemon: s_connect() failed: Connection refused
    May 18 15:24:20 ohdweb pop3d: [Hint: perhaps authdaemond is not running?]
    May 18 15:24:20 ohdweb pop3d: authentication error: Connection refused
    May 19 07:09:40 ohdweb pop3d: Maximum connection limit reached for ::ffff:32.137.159.125
    
    Other than a ton of rejected connections in the mail.warn log, the mail.log has regular postfix mail traffic. I tried starting the daemon and then hitting the log, but nothing showed up.
     
  4. 3DPeruna

    3DPeruna New Member

    One other note... I went back and reconfigured postfix as per the "perfect" setup after I started getting the start failures.
     
  5. falko

    falko Super Moderator

    Please try this:
    Code:
    adduser postfix sasl 
    /etc/init.d/postfix restart
    /etc/init.d/saslauthd start
     
  6. 3DPeruna

    3DPeruna New Member

    I did that as part of the upgrade (as per the instructions). I did it again, just to be sure and get:

    Code:
    The user `postfix' is already a member of `sasl'.
    Postfix restarts.
    Saslauthd doesn't.
     
  7. falko

    falko Super Moderator

    Can you run
    Code:
    /etc/init.d/saslauthd restart
    ?
    What's the output of
    Code:
    ps aux | grep saslauthd
    afterwards?
     
  8. 3DPeruna

    3DPeruna New Member

    The output is:

    Code:
    Stopping SASL Authentication Daemon: (not running).
    Starting SASL Authentication Daemon: (failed).
    
    Code:
    root      5441  0.0  0.0   6948   764 ?        Ss   May18   0:00 /usr/sbin/saslauthd -a pam
    root      5442  0.0  0.0   6948   480 ?        S    May18   0:00 /usr/sbin/saslauthd -a pam
    root      5443  0.0  0.0   6948   456 ?        S    May18   0:00 /usr/sbin/saslauthd -a pam
    root      5444  0.0  0.0   6948   456 ?        S    May18   0:00 /usr/sbin/saslauthd -a pam
    root      5445  0.0  0.0   6948   456 ?        S    May18   0:00 /usr/sbin/saslauthd -a pam
    root     19992  0.0  0.0   3964  1836 pts/0    T    May18   0:00 nano /ete/default/saslauthd
    root     22499  0.0  0.1   8088  2888 pts/0    S+   May20   0:00 saslauthd -a pam -n 5 -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    root     22501  0.0  0.0   8088  1448 pts/0    S+   May20   0:00 saslauthd -a pam -n 5 -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    root     22505  0.0  0.0   8088  1468 pts/0    S+   May20   0:00 saslauthd -a pam -n 5 -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    root     22507  0.0  0.0   8088  1260 pts/0    S+   May20   0:00 saslauthd -a pam -n 5 -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    root     22510  0.0  0.0   8088  1260 pts/0    S+   May20   0:00 saslauthd -a pam -n 5 -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    ohdweb   28626  0.0  0.0   3008   784 pts/2    R+   13:00   0:00 grep saslauthd
    
     
  9. falko

    falko Super Moderator

    Hm, saslauthd seems to be running already.
    Can you run
    Code:
    killall saslauthd
    and then start saslauthd?
     
  10. 3DPeruna

    3DPeruna New Member

    Code:
    saslauthd(5441): Operation not permitted
    saslauthd(5442): Operation not permitted
    saslauthd(5443): Operation not permitted
    saslauthd(5444): Operation not permitted
    saslauthd(5445): Operation not permitted
    saslauthd: no process killed
    
    SORRY: Forgot to SUDO. Killed the processes and restarted. Looks good!
     
    Last edited: May 22, 2009
  11. 3DPeruna

    3DPeruna New Member

    Actually, it doesn't work. Killed the process, the daemon started, but didn't work. Killed the processes and had to issue a

    Code:
    saslauthd -a pam  -n 5  -V -c -m /var/spool/postfix/var/run/saslauthd -r -d
    and leave it running to get SMTP functions properly working.
     

Share This Page