Saslauthd fails to start

Discussion in 'HOWTO-Related Questions' started by Cracklefish, Aug 3, 2011.

  1. Cracklefish

    Cracklefish New Member

    I am using Maildir. All the mailboxes and mysql etc was copied from the old machine (perfect server suse 11.1) as per Mark_NL's instructions earlier in this thread.

    I can't cut and paste out of PuTTY at the moment for some reason, so here are some edited highlights from the mail.log:
    Code:
    Aug 8 12:52:36 linux postfix/postfix-script[6122]: fatal: the Postfix mail server is not running
    Aug 8  18:23:11 xxxx dovecot:auth-worker(default): sql(webmaster@xxxx.co.uk nnn.nnn.nnn.nnnn): password query failed: Table ' dbispconfig.mil.user' doesn't exist
    Aug 8 18:26:59 xxxx postfix/trivial-rewrite[10655]: fatal proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    Aug 9 10:25:03 xxxx postfix/smtpd[4329] fatal: no SASL authentication mechanisms
    Aug 10 10:35:15 xxxx dovecot: dovecot: Fatal: Time adjusted backwards by 10799 seconds. This might cause a lot of problems, so I'll just kill myself now...
    Aug 10 10:25:03 xxxx postfix/smtpd[4329] fatal: no SASL authentication mechanisms
    Aug 10 13:35:26 xxxx amavis[16291]: (16292-04) (!!) TROUBLE in process request: Error writing a SMTP response to the socket: Broken pipe at (eval99) line 987, <GEN67> line 555.
    Aug 10 10:25:03 xxxx postfix/smtpd[4329] fatal: no SASL authentication mechanisms 
    

    The SASL auth message is repeated ad infinitum
    All others occurred only once since firing up the system on Aug 8
    The time message was caused by resetting the system clock to GMT from UTC and explains why the POP3 daemon etc had become disabled.

    I don't think there is anything untoward in the other logs, all the messages seem quite normal

    I can send emails via SMTP STARTTLS
    Mail is arriving at ../domain/user/Maildir/new and is accessible by webmail

    BTW, my reply to your earlier request for info about the apache / mysql problem seems to have been lost.

    You asked me to change the mysql-connect instruction to "localhost" from the FQDomainname.

    The result of that was for the error message to change to:

    Code:
    Access denied for user 'c4wmstudio'@'localhost' (using password: YES) 
     
  2. falko

    falko Super Moderator

    Please check if all required MySQL tables exist.
     
  3. Cracklefish

    Cracklefish New Member

    Yes it's there and I can open it with phpMyAdmin
     
  4. falko

    falko Super Moderator

    And is the database name correct?
     
  5. Cracklefish

    Cracklefish New Member

    Sorry, I misunderstood your request in my last reply. For some reason I thought you were refering to the website database.

    Anyhow, the mail_??? tables are all there and have data in them.

    I have done some more investigation and if I set the pop3 login connection security to "none" then the mail is downloaded so this would appear to be a SSL/TLS support issue.
     
  6. Cracklefish

    Cracklefish New Member

    Yes, as far as I can see, all the db and table names are identical with the names in the default database (which I saved prior to importing) and the database imported from the old system.

    As for the website database, in desperation to get the site back up, I deleted the database with ISPC3 and then recreated it then copied the table files from the old system. It now works ok ( 1 down, 1 to go!)
     
  7. falko

    falko Super Moderator

    Maybe you should open your database in phpMyAdmin and try to repair your tables. Maybe that fixes some problems.
     
  8. Cracklefish

    Cracklefish New Member

    Oops! maybe that was not such a good idea.

    I checked all the tables and they appeared to be identical with the ones in the old system so I tried to import them again but phpmyadmin would not import the dump from the old system. It came back with "File could not be read". So I copied the whole directory and chowned and chmoded it allas I had had to do when I replaced the web site databases.

    After entering name and password in ISPC it just returns to the login page with no error message. It must be reading the password as it gives a password error if I mispell the password. Client logins are the same.

    When I originally set up the system phpmyadmin allowed DB import for the dpispconfig and web databases.

    POP mail is arriving at ../Maildir/new. SMTP is running with StartTLS auth but still I can't download any mail as the SSL/TLS is failing

    /var/log/mail gives

    Code:
    [I]date time server [/I]dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip-127.0.0.1, secured
     
  9. falko

    falko Super Moderator

  10. Cracklefish

    Cracklefish New Member

    Sorry for the dalay, I "had" to go away on holiday!

    I restored the database as per your instruction and now the ISPC admin login works ok but I still cannot download any emails from the pop boxes. Webmail works fine and mail is being delivered to the pop boxes and outgoing mail is being sent by smtp.

    Just a thought, the original mail system was using Maildir but the new one is using Dovecot. Is there any difference in the config that might explain why the mail download won't work?
     
    Last edited: Aug 31, 2011
  11. falko

    falko Super Moderator

    Dovecot is using Maildir as well. Did you use Courier in your previous setup, or Dovecot as well?

    Do you get any error messages? Does your firewall allow access on port 110?
     
  12. Cracklefish

    Cracklefish New Member

    The previous setup was just Courier as per Perfect Server Opensuse 11.1

    My reference to Maildir was to the folder /var/vmail/maildomain/user/Maildir

    Also, I can download mail if the passwords are sent in the clear. It's just SSL/TLS that is failing.
     
  13. Cracklefish

    Cracklefish New Member

    Yippee! I've fixed it.

    The thread title has become a little missleading because the problem refered on the old server. When that was found to have bad sectors on the disk I hurriedly brought into service a new machine that I was in the process of configuring.

    Anyway, the problem was the Dovecot config. It seems there are some discrepencies in the documentation. SSL/TLS is not enabled by default and the security certificate is not included in the rpm, at least not the one available from openSUSE. So the fix was to comment out, or change to "yes", the following line in SSL SETTINGS section of /etc/dovecot/dovecot.conf.
    Code:
    ssl = no
    If the certificate is not present there will be an error message when you restart Dovecot.

    There is a wiki to create the certificate at
    HTML:
    http://wiki.dovecot.org/SSL/CertificateCreation
     
: saslauthd

Share This Page