Saslauthd Error

Discussion in 'Server Operation' started by madie, Oct 16, 2006.

  1. madie

    madie New Member

    have install a Server with Debian 3.1, ISPConfig and PHP5 like in the Howtos perfect Debian. Now I have a problem with Sending Mails via sSMTP. STARTTLS works fine.

    the error in my mail-program:
    Code:
    [*] Connection established to ***
    >> 0061 220 ***.serverkompetenz.net ESMTP Postfix (Debian/GNU)
    << 0022 EHLO [192.168.99.11]
    >> 0034 250-***.serverkompetenz.net
    >> 0016 250-PIPELINING
    >> 0019 250-SIZE 10240000
    >> 0010 250-VRFY
    >> 0010 250-ETRN
    >> 0022 250-AUTH LOGIN PLAIN
    >> 0022 250-AUTH=LOGIN PLAIN
    >> 0014 250 8BITMIME
    << 0012 AUTH LOGIN
    >> 0018 334 VXNlcm5hbWU6
    << 0034 ZGllZGVybmV0LmRlX3dlYm1hc3Rlcg==
    >> 0018 334 UGFzc3dvcmQ6
    << 0022 S2F0aHJpbkthdGhyaW4=
    >> 0034 535 Error: authentication failed
    
    the error in mail.log:
    Code:
    Oct 16 11:55:24 *** postfix/smtpd[17422]: setting up TLS connection from ***
    Oct 16 11:55:24 *** postfix/smtpd[17422]: TLS connection established from ***: TLSv1 with cipher DES-CBC3-SHA (168/168 bits)
    Oct 16 11:55:24 *** postfix/smtpd[17422]: connect from ***
    Oct 16 11:55:24 *** postfix/smtpd[17422]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
    Oct 16 11:55:24 *** postfix/smtpd[17422]: warning: ***: SASL LOGIN authentication failed
    
    If I try to restart saslauthd, I get the error:
    Code:
    # /etc/init.d/saslauthd force-reload
    Stopping SASL Authentication Daemon: (not running).
    Starting SASL Authentication Daemon: (failed).
    my /etc/default/saslauthd:
    Code:
    # This needs to be uncommented before saslauthd will be run automatically
    START=yes
    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
    # You must specify the authentication mechanisms you wish to use.
    # This defaults to "pam" for PAM support, but may also include
    # "shadow" or "sasldb", like this:
    # MECHANISMS="pam shadow"
    
    MECHANISMS="pam"
    # ls -la /var/spool/postfix/var/run/saslauthd:
    Code:
    total 12
    drwxr-xr-x  2 root root 4096 Oct 16 11:59 .
    drwxr-xr-x  3 root root 4096 Oct  9 08:54 ..
    srwxrwxrwx  1 root root    0 Oct 14 14:56 mux
    -rw-------  1 root root    0 Oct 16 11:59 mux.accept
    -rw-------  1 root root    4 Oct 14 14:56 saslauthd.pid
    # ls -la /var/run/saslauthd:
    Code:
    total 8
    drwx--x---   2 root sasl 4096 Oct  9 08:48 .
    drwxr-xr-x  11 root root 4096 Oct 16 10:34 ..
    my /etc/postfix/master.cf has the lines:
    Code:
    # only used by postfix-tls
    tlsmgr    fifo  -       -       n       300     1       tlsmgr
    smtps     inet  n       -       n       -       -       smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    587       inet  n       -       n       -       -       smtpd -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
    
    Please help me!

    Madie
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I think you need to chroot the SMTPS daemon:

    Code:
    smtps     inet  n       -       [B][COLOR="Red"]-[/COLOR][/B]       -       -       smtpd -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
     
  3. madie

    madie New Member

    Thanks, it works fine now .. only a little "n" too much ...
     

Share This Page