saslauthd eats 800mb

Discussion in 'Installation/Configuration' started by loge, Mar 11, 2009.

  1. loge

    loge New Member

    Hi,

    i ve installed the "Perfect Setup for Debian Lenny" with regards to ISPconfig and i have severe memory problems on a 1,5 gig RAM VMWare guest. I ve done some research and it turns out that "saslauthd" eats 800 Mb of RAM which is damn much.... way too much of course.

    Does anybody have a clue why this is the case? With that memory consumption i am running out-of-memory very often and swap is heavily active which makes the box slow.

    Then i have some more issues i dont understand, there are some mails in the Queue that wont get delivered as mentioned in ISPConfig3 Monitor:

    AE39583AF3 1427 Sun Mar 8 20:47:15 xxx@logemann.org
    (host mail.rosenhof-os.de[88.198.67.48] said: 450 4.7.1 Client host rejected: cannot find your hostname, [193.41.253.142] (in reply to RCPT TO command))
    xxx@rosenhof-os.de

    C744883AF8 18278 Wed Mar 11 09:51:16 xxx@apdesign.de
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    xxx@logentis.de

    The first one seems to be an outbound message right? The Domains logemann.org and logentis.de are mine (i xxx the real addresses). The second one got delivered while i am writing this.... the first one... i dont know whats wrong with it. Perhaps DNS reverse lookup doesnt work on my domain?

    Then the last thing is really crazy. I am getting this in the mail.err log:

    Mar 11 11:14:51 isp2 postfix/smtpd[2942]: warning: localhost[127.0.0.1]: SASL LOGIN authentication failed: authentication failure
    Mar 11 11:14:51 isp2 postfix/smtpd[2949]: warning: localhost[127.0.0.1]: SASL LOGIN authentication failed: authentication failure
    Mar 11 11:14:51 isp2 postfix/smtpd[19856]: warning: localhost[127.0.0.1]: SASL LOGIN authentication failed: authentication failure
    ...

    AS you can see, its getting called very often and i dont know why localhost is authenticating and against what? I ve searched for more infos in other logs but couldnt find anything.

    Marc




    Marc
     
    Last edited: Mar 11, 2009
  2. loge

    loge New Member

    Forget the last one regarding LOGIN AUTH failed. It was a bug tracking system on "localhost" with wrong SMTP credentials :mad:

    The sasl daemon still makes me nervous, its getting bigger second by second. I cant restart it every 2 hours :)

    Marc

    Update: overcome the SASL problem by spawning a new process on every mail with the THREADS = 0 in the saslauthd configuration. Definitely not the golden path because now i have a lot more process work on my box than when running with threads but better than OOM issues. I think there is a big problem with saslauthd togehter with PAM on this type of installation.
     
    Last edited: Mar 11, 2009

Share This Page