saslauthd auth failure

Discussion in 'Server Operation' started by luca, Dec 3, 2006.

  1. luca

    luca New Member

    Hello all,
    nice forum. I discovered it browsing for solutions to my postfix problem...
    I followed the "perfect debian install" how to instructions and got a bit further but still no luck...

    As my provider continually gets on the blocklists i decidede to put up an authenticated SMTP on the webserver i normally use which already had Postfix for some processes running on it (nagios - cacti and stuff like that)

    i installed the various packages, configured sasldb2 in the postfix chroot...
    added a test user but i can't get it to authenticate....

    i'm using
    to get the string to pass to the server via AUTH PLAIN...

    an extract from the logs:

    anybody an idea what i'm missing?

    Thank you in advance, Luca
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The perfect setup howto configures sasl with system user accounts, not with the sasl userdb. Just add a system user and you will be able to authenticate with SMTP.
  3. luca

    luca New Member

    Till, thank you for your answer.

    I had the mechanism set to sasldb. Just for being sure i brought it back to pam and tested autenticating as a system user but still i get authentication failed.

    am i using the correc way to get the encoded string to check if auth is working?

    I am quit lost. :)

    Ciao, Luca

    PS: Addition: looking on similar threads i found a refernce to testsaslauthd and got:

    testsaslauthd -u test -p testpass -f /var/spool/postfix/etc/sasldb2
    connect() : Connection refused

    any new idea?
    Last edited: Dec 3, 2006
  4. luca

    luca New Member

    as it looks like i'm confiusing things.

    new test...

    testsaslauthd -u test -p testpass -f /var/spool/postfix/var/run/saslauthd/mux
    0: OK "Success."

    so something is running the problem is i don't know what :rolleyes:

    reading thorough the manpages... :)

    Any input is still welcome :)

  5. luca

    luca New Member

    and finally.. :)

    checking auth.log (which i had a look at before but at that time saslauthd was not starting so it had no hints) i found i was autenticationg against the wrong username... i had the $myhostname added by saslauthd.

    i seem to remeber another thread referred to that...

    smtpd_sasl_local_domain =

    solved the problem.

    Thanks for reading and helping :)


Share This Page