Sasl mechanism problem

Discussion in 'Server Operation' started by joefalchetto71, Mar 20, 2008.

  1. joefalchetto71

    joefalchetto71 New Member

    Hello, i tried the Perfect Setup Debian Etch by Falko, (very good guide) i did it all exactly but i got an error starting saslauthd.
    "no SASL authentication mechanisms error" because PAM mechanisms.
    I'm blocked on page 5 of tutorial what can i do ?



    I got Linux Debian 4.03.

    Thanks for help

    Massimiliano:)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/sasl/smtpd.conf and /etc/default/saslauthd?
     
  3. joefalchetto71

    joefalchetto71 New Member

    The content of requested files

    /etc/postfix/sasl/smtpd.conf:

    pwcheck_method: saslauthd
    mech_list: plain_login

    /etc/default/saslauthd :
    #
    # Settings for saslauthd daemon
    #

    # Should saslauthd run automatically on startup? (default: no)
    START=yes

    # Which authentication mechanisms should saslauthd use? (default: pam)
    #
    # Available options in this Debian package:
    # getpwent -- use the getpwent() library function
    # kerberos5 -- use Kerberos 5
    # pam -- use PAM
    # rimap -- use a remote IMAP server
    # shadow -- use the local shadow password file
    # sasldb -- use the local sasldb database file
    # ldap -- use LDAP (configuration is in /etc/saslauthd.conf)
    #
    # Only one option may be used at a time. See the saslauthd man page
    # for more information.
    #
    # Example: MECHANISMS="pam"
    MECHANISMS="pam"

    # Additional options for this mechanism. (default: none)
    # See the saslauthd man page for information about mech-specific options.
    MECH_OPTIONS=""

    # How many saslauthd processes should we run? (default: 5)
    # A value of 0 will fork a new process for each connection.
    THREADS=5

    # Other options (default: -c)
    # See the saslauthd man page for information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    # Note: See /usr/share/doc/sasl2-bin/README.Debian
    OPTIONS="-m /var/spool/postfix/var/run/saslauthd -r -c"


    Massimiliano
     
  4. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer

    Hi joefalchetto71,

    you have a typo in your configuration (/etc/postfix/sasl/smtpd.conf).

    Please change

    Code:
    mech_list: plain_login
    to

    Code:
    mech_list: plain login
    Best regards,

    Olli
     
  5. joefalchetto71

    joefalchetto71 New Member

    Now is working

    Thank you Olli, now saslauthd is working good.
    I'm too distracted :( .

    Special thanks to Falko Timme and his perfect guide.

    Now i'll try to install and configure ispconfig :eek:


    Thank you very much.

    Happy Easter to all

    Massimiliano
     

Share This Page