SASL LOGIN authentication failed: authentication failure

Discussion in 'ISPConfig 3 Priority Support' started by lusso64, Jun 3, 2016.

  1. lusso64

    lusso64 New Member HowtoForge Supporter

    Hi,
    For no apparent reason I have been unable to send email from an email client, but squirrelmail works fine. Everything was good until 24 hours ago.
    When I try to send email, I see this error in mail.log


    Jun 2 22:49:21 websrv postfix/smtpd[14220]: lost connection after AUTH from external.com[1.2.3.5]
    Jun 2 22:49:21 websrv postfix/smtpd[14220]: disconnect from external.com[1.2.3.5]
    Jun 2 22:49:21 websrv postfix/smtpd[14220]: connect from external.com[1.2.3.5]
    Jun 2 22:49:21 websrv postfix/smtpd[14220]: warning: external.com[1.2.3.5]: SASL LOGIN authentication failed: authentication failure


    It makes no sense as nothing has changed since I updated to version 3.0.5.4p8 when that version first was released.

    Thanks in advance for any and all advice.

    Dave
     
  2. lusso64

    lusso64 New Member HowtoForge Supporter

    Well, I don't know how, but I applied the update to 3.0.5.4p9 and everything is now working again.
    I am very happy that it is working, but I am concerned about what happened - what if this happens again?
    Thanks, Dave
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Something must have changed, this can have been a Linux system update or another issue with the SASL system. The ISPConfig updater can repair this issue automatically i most cases, so if this happens again, run the update.php script and let the update reconfigure the services as you did this time.
     
    lusso64 likes this.
  4. lusso64

    lusso64 New Member HowtoForge Supporter

    Hi till, thanks for the quick response. I didn't know I could run the update just like that - very cool!
    Thanks again, Dave
     
  5. lusso64

    lusso64 New Member HowtoForge Supporter

    Hi till, this has happened again. I am still unsure of the reason but when II get some time I will investigate.

    In the meantime I have tried to run the update installer again and it returns saying "There are no updates available for ISPConfig 3.0.5.4p9" as expected. I looked for an update.php script and didn't find one, although I found some with similar names in /tmp/ispconfig3_install/server/scripts.

    Can you please point me in the right direction for the correct script?

    Thanks, Dave
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the ispconfig tar.gz file, unpack it and run the update.php script in the install folder.
     
  7. lusso64

    lusso64 New Member HowtoForge Supporter

    Thanks again till - that did the trick.

    I did note in the terminal output the following warnings...

    * Stopping Postfix Mail Transport Agent postfix
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    ...done.
    * Starting Postfix Mail Transport Agent postfix
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    /usr/sbin/postconf: warning: /etc/postfix/master.cf: unused parameter: smtpd_bind_address=127.0.0.1
    ...done.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Comment out the smtpd_bind_address=127.0.0.1 parameter in master.cf (must be near the end) by adding a # in front of the line and restart postfix.
     

Share This Page