SASL Login authentication error after update

Discussion in 'Installation/Configuration' started by arraken, Sep 24, 2013.

  1. arraken

    arraken Member HowtoForge Supporter


    I have updated from ubuntu 10.04LTS to 12.04LTS, and have the same postfix error that some other users already reported. More specifically, it's exactly like SpeedyB's errors in this thread: LOGIN authentication failed: mechanism

    So i got the following error in mail.log, whenever somebody wanted to send a mail:

    SASL LOGIN authentication failed: no mechanism available
    and the following warnings whenever i restarted postfix:

    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_maildir_limit_message="The user you are trying to reach is over quota."
    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_mailbox_limit_override=yes
    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_maildir_extended=yes
    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_overquota_bounce=yes
    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: virtual_create_maildirsize=yes
    /usr/sbin/postconf: warning: /etc/postfix/ unused parameter: smtpd_bind_address=
    after installing the VDA patch as described in this tutorial / only the following errors remained:

    postconf: warning: /etc/postfix/ unused parameter: virtual_create_maildirsize=yes
    postconf: warning: /etc/postfix/ unused parameter: smtpd_bind_address=
    So far it's all the same as in SpeedyB's thread. But i cannot get rid of the "SASL LOGIN authentication failed: no mechanism available" error, even though i did what many others did to resolve the problem successfully:

    First, I edited /etc/postfix/sasl/smtpd.conf to contain the following:

    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: sql
    sql_engine: mysql
    sql_user: ispconfig
    sql_passwd: <yourpass>
    sql_database: dbispconfig
    sql_select: select password from mail_user where login = '%u@%r'
    Second, I reconfigured all services via the ispconfig update script.

    Third, i changed a line in /etc/default/saslauthd from
    OPTIONS="-c -r -m /var/spool/postfix/var/run/saslauthd"
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    So what else can be the problem? At the moment i temporarily "solved" the problem, buy uncommenting the "auxprop_plugin: sql" line in the smtpd.conf. If i do that, the error message disappears and my users can send mail. But i think this can hardly be a permanent solution, as it surely creates a security risk, right? (I don't know exactly which one, so if somebody knows, please clarify. :) )
    Last edited: Sep 24, 2013

Share This Page