Sasl Issues

Discussion in 'HOWTO-Related Questions' started by volksman, Nov 18, 2007.

  1. volksman

    volksman New Member

    Hey All!

    I ran through the Virtual Users/Postfix howto a while back and had everything working except the outgoing smtp stuff since I just use my ISPs server. However I'd like to start using mine. Problem is SASL won't auth my user. I've read around at some of the problems and checked everything I can think of.

    saslauthd is running and its pid file is correct.

    My error is this:

    If I run:
    I'm at a loss as to why it doesn't work. Any ideas?

    PS Gutsy Gibbon and likely used the Edgy howto since it was the only one there at the time.
  2. falko

    falko Super Moderator ISPConfig Developer

  3. volksman

    volksman New Member

    hey Falko!

    I checked again and it does already look identical. I have been playing with the OPTIONS or PARAMS lines as they seem to be a bit different in some of the howto's but it so far hasn't fixed the problem. Each change brings a different error message though....

    Right now I believe all my files are as you have described in your howto.

    I'm wondering if I need to upgrade my Gutsy or something. Maybe one of my packages is busted....
  4. volksman

    volksman New Member



    I believe that is all the relevant files associated with my issue. Any help would be appreciated. BTW an upgrade didn't help as all the sasl packages were up to date already.
  5. falko

    falko Super Moderator ISPConfig Developer

    Does it work if you do:
    chmod 777 /var/spool/postfix/var/run/saslauthd
  6. volksman

    volksman New Member

    hey falko!

    Tried that...same results...however I think it may have something to do with the sock file not being found. I haven't had a lot of time to look into this (terribly sick, and a newborn keep things busy as it is).

    My hunch is that the sock file is being created somewhere else that sasl can't find. I saw it in another howto that the sock location was being defined.

    Any pointers on where that is and how its set is very much appreciated as it would save me some time!

    Thanks for the help so far!
  7. falko

    falko Super Moderator ISPConfig Developer

    Take a look at /etc/init.d/saslauthd. It's possible that it contains some code that changes the permissions of /var/spool/postfix/var/run/saslauthd back. If you find such code, comment it out and restart saslauthd.
  8. volksman

    volksman New Member

    I noticed you posted a new HOWTO for Gutsy. Was there much different between it and the Edgy/Feisty implementations?

    BTW the saslauthd script doesn't seem to modify perms on the folder:

    total 940
    drwxrwxrwx 2 root root 4096 Nov 20 19:30 .
    drwxr-xr-x 3 root root 4096 Oct 6 12:06 ..
    -rw------- 1 root root 0 Nov 20 19:30 cache.flock
    -rw------- 1 root root 945152 Nov 20 19:30 cache.mmap
    srwxrwxrwx 1 root root 0 Nov 20 19:30 mux
    -rw------- 1 root root 0 Nov 20 19:30 mux.accept
    -rw------- 1 root root 5 Nov 20 19:30
  9. volksman

    volksman New Member

    Not sure if this helps any but I ran saslauthd manually on the command line with the same params you'd find in /etc/default/saslauthd and enabled debugging:

    Socket is in the mux file?

    Anyways when I run testsaslauthd I need to specify the following for it to work:

    So I re-ran saslauthd from the init script as opposed to manually and ran testsaslauthd again. As long as I specify the -f flag it will work. When I stop it gives me a connection refused....Something in the config is not pointing to the right mux file....
    Last edited: Nov 23, 2007
  10. volksman

    volksman New Member

    Ok...I think I have this one figured I just need to figure out how to fix it. It seems that pam is trying to connect to my mysqldb on /var/run/mysqld/mysqld.sock, however I use xampp so it isn't there. I modified my /etc/mysql/my.cnf file to point to the correct socket location but it seems pamd doesn't abide. Any ideas how to force pamd/saslauthd to look at the right location?
  11. volksman

    volksman New Member

    I've confirmed the above by creating a symlink to the mysql.sock file created by xampp...Everything works fine once I do that. However that link will die if I restart the server I believe.

    So any help in how to point pam.d config to the right socket would be very helpful!
  12. volksman

    volksman New Member

    Got it all figured out. In case anyone is interested all you need to do is change:


    Note the host= entry.

Share This Page