SASL Installation Issue on ISPConfig 3.0.2.1

Discussion in 'Installation/Configuration' started by kinai, Apr 3, 2010.

  1. kinai

    kinai Member

    Hi all,

    I'm installing ISPConfig 3.0.2.1 from scratch following INSTALL_DEBIAN_5.0_dovecot_bind.txt in the package, on a fresh debian 5.0 server.

    1. It seems that install of sasl is missing. It must launch

    apt-get install apt-get install libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql

    like mention in "Perfect Server" instruction.

    2. Last version of SASL don't create /etc/init.d/saslauthd script and /etc/default/saslauthd script. It's create only *.dist.inc.php files.

    3. Not sure yet, but after launching ISPConfig installer, it seems that SASLis not configured. I don't have error during process but restarting service display "Start=Yes" to enable service.

    Thanks,
    Regards,
     
  2. till

    till Super Moderator

    There is nothing missing, this setup uses dovecot as authentication source in postfix, sasl is only used if you install courier and not dovecot.
     
  3. kinai

    kinai Member

    ok, so maybe a little problem with install script.

    If dovecot is using on the server, Install Script is even displayed "Configuration SASL" and try to start SaslAuthd Daemon.

    Perhaps, is it possible to detect if DOVECOT or COURIER is used (maybe already done) and not showing SASL information in case of DOVECOT is detected.

    Thanks,
    Regards,
    Kinai
     
  4. kinai

    kinai Member

    In addition, main.cf show this :

    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, ...

    If SASL is not installed, this command seems to be not required ...
     

Share This Page