SASL Errors

Discussion in 'Installation/Configuration' started by Jim Locke, Feb 12, 2012.

  1. Jim Locke

    Jim Locke New Member

    Had the initial SASL error

    After trying this: Noticed some errors as it installed debs. Went by to qwk to catch what they were

    From ISPConfig/Show Mail Log "warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory"

    Running Unbuntu 11.10 (32bit), Multi Server Build (6) SquirrellMail

    Squirrell works in/out
    Email Client only in. SMTP auth fails so no sending

    Background, Linux newb!
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to restart saslauthd?
  3. Jim Locke

    Jim Locke New Member

    So far I've tried everything I could find here. Have it back to "no mechanism." The configs are exactly as per.The only thing I am not sure about is the output of postconf | grep sasl , it appears to have entries that aren't listed in any config file. Tried the locate cmd to see if there is alternate configs. All are looking good. At a loss to what prob is.

    I was thinking of rebuilding mail server with Ubuntu 11.04 just to get past this 1 error
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you download the correct packages (for 32bit systems)?
  5. Jim Locke

    Jim Locke New Member

    Yes, correct pkges loaded, followed these steps:

    1) remove all mail boxes/aliases
    2) remove all email domains
    3) remove mail server
    4) formatted/installed 11.04/64bit
    5) installed all applicable apps for email as per multiserver
    6) installed/removed ispconfig (a few times) kept showing a db connection error
    7) In ISPConfig control panel config'd server. looked good
    8) made 1 email domain, 1 email box, tested good (email client/squirrel in/out)
    9) made another domain and 2 email boxes - BAD - no squirrel, all inbound deleted
    10) frustrated! LOL
    11) noticed DNS issues with Bind
    12) no alias's (or cname) appear to be working
    - dig @ns1 any - shows all records - good
    - dig @ns2 any - shows all records - good
    - did via putty on each ns server - so internally all good
    - shows & as working
    - shows all is well except not showing www record
    - I can ping from outside all A records & alias's - good
    - what I can not do is nslookup <alias> - shows unknown domain
    - - BAD
    - but gives me the "It Works"
    - and - Squirrel login - Works

    This is going no where fast :(

    Please say you have an idea whats going wrong, I have 3 domains that is actively using the ns servers. I have no probs rebuilding the mail server or adding another, but ns servers need to keep running
    Last edited: Feb 16, 2012
  6. Jim Locke

    Jim Locke New Member

    QWK Update

    DNS Alias's still not right
    Email for all is flowing
    Working out the spam stuff is loads of fun

    Anyone Know how to move all tagged ***SPAM*** to the Junk Folder?


Share This Page