SASL error after Debian upgrade

Discussion in 'Installation/Configuration' started by adnese, Apr 18, 2011.

  1. adnese

    adnese New Member

    Hello Till,

    after performing debian stable updates, postfix stopped working properly.
    logs:

    Apr 18 09:39:37 voradesign postfix/smtpd[1275]: fatal: no SASL authentication mechanisms
    Apr 18 09:40:38 voradesign postfix/smtpd[1659]: fatal: no SASL authentication mechanisms
    Apr 18 09:40:38 voradesign postfix/smtpd[1661]: fatal: no SASL authentication mechanisms

    and

    Apr 18 09:54:11 voradesign postfix/smtp[2897]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Apr 18 09:54:11 voradesign postfix/smtp[2897]: 25A051017A: to=<xxxx@gmail.com>, relay=none, delay=379, delays=379/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

    sasl directives in main.cf:

    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth

    Any idea how to get the mailserver / sasl working ?

    Thank you,

    Adrian
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    download ispconfig 3.0.3.3, unpack it and run update.php script. Choose to reconfigure services during update.
     
  3. adnese

    adnese New Member

    Hello Till,

    it start working again, after restart of postfix and all components (dovecot, amavis). I didn't change anything on the configuration and after half hour of troubleshoot everything became accessible again (webmail login/ user login).

    Thanks so far.

    Regards,

    Adrian
     

Share This Page