SASL authentication failure

Discussion in 'Installation/Configuration' started by clart001, Jan 7, 2010.

  1. clart001

    clart001 New Member

    I set up an Ubuntu Jaunty Jackalope (Ubuntu 9.04) vps server with ISPconfig 2 following this tutorial http://www.howtoforge.com/perfect-server-ubuntu-9.04-ispconfig-2

    All seems to work quite allright but now I run into a problem regarding postfix and smtp.

    When I try to send an email I get:

    mail.log
    Code:
    postfix/smtpd[6517]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    postfix/smtpd[6517]: warning: host250-228-dynamic.17-87-r.retail.telecomitalia.it[87.17.228.250]: SASL LOGIN authentication failed: generic failure
    postfix/smtpd[6517]: disconnect from host250-228-dynamic.17-87-r.retail.telecomitalia.it[87.17.228.250]
    
    Could anyone help me?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please try this:
    Code:
    adduser postfix sasl
    /etc/init.d/postfix restart
    /etc/init.d/saslauthd start
     
  3. clart001

    clart001 New Member

    First of all, thank you Falko.
    I have done how you suggested me but it seems not work again.

    Any other suggests?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ps aux | grep saslauthd
    ?
     
  5. clart001

    clart001 New Member


    Code:
    root@vps314345:~# ps aux | grep saslauthd
    root      5348  0.0  0.1   8416   872 ?        Ss   Jan07   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      5351  0.0  0.0   8416   508 ?        S    Jan07   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      5352  0.0  0.0   8416   424 ?        S    Jan07   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      5353  0.0  0.0   8416   424 ?        S    Jan07   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root      5356  0.0  0.0   8416   424 ?        S    Jan07   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
    root     10077  0.0  0.1   3336   780 pts/1    R+   11:23   0:00 grep saslauthd
    
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/postfix/sasl/smtpd.conf and /etc/default/saslauthd?
     
  7. clart001

    clart001 New Member


    /etc/postfix/sasl/smtpd.conf
    Code:
    pwcheck_method: saslauthd
    mech_list: plain login
    
    /etc/default/saslauthd

    Code:
    START=yes
    
    DESC="SASL Authentication Daemon"
    
    NAME="saslauthd"
    
    MECHANISMS="pam"
    
    MECH_OPTIONS=""
    THREADS=5
    
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
    
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ls -la /var/spool/postfix/var/run/saslauthd/
    ?

    What virtualization technique do you use (OpenVZ/Virtuozzo, Xen, KVM, VMware, etc.)?
     
  9. clart001

    clart001 New Member

    Code:
    root@vps314345:~# ls -la /var/spool/postfix/var/run/saslauthd/
    totale 940
    drwx--x--- 2 root sasl   4096 2010-01-07 15:02 .
    drwxr-xr-x 3 root root   4096 2009-11-02 19:47 ..
    -rw------- 1 root root      0 2010-01-07 15:02 cache.flock
    -rw------- 1 root root 945152 2010-01-07 15:02 cache.mmap
    srwxrwxrwx 1 root root      0 2010-01-07 15:02 mux
    -rw------- 1 root root      0 2010-01-07 15:02 mux.accept
    -rw------- 1 root root      5 2010-01-07 15:02 saslauthd.pid
    
    We use Xen
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks ok. Are you absolutely sure that the postfix user is a member of the sasl group? What's the output of
    Code:
    grep sasl /etc/group
    ?
     
  11. clart001

    clart001 New Member

    Code:
    root@vps314345:~# grep sasl /etc/group
    sasl:x:45:postfix
    
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Hm, looks ok. I have no idea what the problem is... :(
     

Share This Page