SASL and PAM

Discussion in 'HOWTO-Related Questions' started by juliyana, Jul 31, 2008.

  1. juliyana

    juliyana New Member

    Hello,

    I am using SASL and PAM on Redhat 5.0. I saw your posting on the net. But every time I run testsaslauthd I get the following error
    Jul 30 13:59:13 vernal saslauthd[5379]: do_auth : auth failure: [service=smtp] [realm=] [mech=pam] [reason=PAM auth error]
    Please help.

    My /etc/pam.d/smtp
    #%PAM-1.0
    auth required /lib/security/pam_stack.so service=system-auth
    account required /lib/security/pam_stack.so service=system-auth
    session required /lib/security/pam_stack.so service=system-auth
    auth required /lib/security/pam_afs.so
    account required /lib/security/pam_afs.so
    session required /lib/security/pam_afs.so


    Thx Juliyana
     
  2. falko

    falko Super Moderator ISPConfig Developer

    How did you set up your email accounts? Which email server (Postfix/Sendmail/...) are you using?
     
  3. juliyana

    juliyana New Member

    Hi,
    We have sendmail running on this server only as a relay server.

    Juliyana
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate smtpd.conf
    ?
     
  5. juliyana

    juliyana New Member

    PLEASE HELP with SASL and PAM

    Hi falko,

    my /etc/pam.d/smtp looks like this

    #%PAM-1.0
    auth required /lib/security/pam_afs.so
    account required /lib/security/pam_afs.so

    But when I run testsaslauthd,I still get the following error.
    auth failure: [service=smtp] [realm=] [mech=pam] [reason=PAM auth error]

    Thanks for all your help.
    Juliyana
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is there no smptd.conf on your server?
     

Share This Page